Support » Plugin: WordPress Move » Can't get it to work from web to Mac

  • Been using this plugin fine to get my locally developed WP sites out onto the web, it really is marvelous.

    But I can’t get it to work going the other way. I’m running Mountain Lion on a Mac, which doesn’t have ftp server in the control panel any more, so I enabled it with the command:

    enable ftp on mountain lion with this sudo launchctl load -w /System/Library/LaunchDaemons/ftp.plist

    in a terminal window.

    I then checked that local ftp was working by successfully logging in with Cyberduck to localhost, even as far as the exact path I wanted to the local WP installation I want to update from the web. (I’m using MAMP to run WP locally.)

    Entered “localhost” in the migration settings, enter my Mac’s password, hit transfer, and Migration Assistant status says: Connecting to localhost:21… Success!
    Logging in as donald using password… Failed!
    Operation terminated…

    I’ve tried setting up another administrator account with a different logon and password, and logging into that first with Cyberduck to check it works, and it gives the same error.

    I went through all the docs and support threads on the developer’s website, and I see most people seem to be able to get Migration Assistant to work, but there were a few VERY frustrated people obviously trying to use Migration Assistant to move file TO their local machine – a Macintosh – and failing, and basically being given the runaround in the support forums, implying that they have configured something wrongly.

    Is there anything I can do to get this to work?

    I am going to get around this by making a local backup using Migration Assistant on the web machine, and use Cyberduck to copy it to my local machine, and completing the transfer there, but I would much rather get it to work “properly” and in a single step, as it is really wonderful when it does work!

Viewing 2 replies - 1 through 2 (of 2 total)
  • PS I just wanted to add that my alternative two-stage migration plan worked.

    I moved the migration files by “hand” from the web server, which I created by running Migration Assistant after configuring it to store them to the server itself (in other words, configuring the ftp destination settings so they are no longer to “localhost”), but I still entered my local url in the “new” url slot.

    I then copied the files using Cyberduck to my local machine, and then ran the final phase of the restore locally, and it worked perfectly.

    I think there is something broken in Migration Assistant in its ftp password verification on web to local access to a Mac running MAMP….

    I have the same exact issue. I can log on to my Mac FTP via Filezilla, even on my phone’s browser, but WordPress Move just won’t connect. I tried to migrate from local site to local ftp and from live to local, but no luck.

    I’m gonna try your solution soon, although it seems like a bit of a hassle to do each time.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't get it to work from web to Mac’ is closed to new replies.