Support » Plugin: Mobile Theme Ads for Jetpack » Can't get it to work

  • Hi,

    I’ve tried a lot of options, but i simply can’t get this plugin to work.
    I have latest versions of Jetpack (mobile enabled) and wordpress 3.8.

    I’ve installed your plugin, and configured it accordingly (i’ve tried various dimensions) with all the values from AdSense (i’ve also tried with and without the “ca-pub-” string).

    No ads are shown. I’ve tried on Safari on a iPhone 5, but also Chrome on the same phone. I’ve also configured my iPhone’s User-Agent on desktop Firefox, and still no go. Cleared cache, and made sure that CloudFlare is in dev mode.

    Also, i have Adsense Explosion, and disabled the mobile ads to avoid conflict. I’ve also noticed that the mobile site detection is much more exhaustive on AdSense.
    Could this be a bug with recent versions?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jeremy Herve


    Jetpack Mechanic

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:


    Tried it in a few combinations, but, no luck yet.

    I only managed to get async ads showing. I’ve altered your code:

    function jp_mini_ads_show_ads( $content ) {
    $options = get_option( ‘jp_mini_ads_strings’ );
    $ads = ‘
    <script type=”text/javascript”>
    google_ad_client = “‘. $options[‘google_ad_client’] .'”;
    google_ad_slot = “‘. $options[‘google_ad_slot’] .'”;
    google_ad_width = ‘. $options[‘google_ad_width’] .’;
    google_ad_height = ‘. $options[‘google_ad_height’] .’;
    <script type=”text/javascript” src=”//”></script>


    Plugin Author Jeremy Herve


    Jetpack Mechanic

    When you use the unmodified plugin and enter your Google Adsense settings, what do you see in the Mobile Theme? Do you see an empty space instead of the ads?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can't get it to work’ is closed to new replies.