Support » Plugin: PDF 2 Post » Can’t get it to work

  • Resolved WDOrkoskey

    (@wdorkoskey)


    Hi, I’ve tried setting up the plugin both on a shared server through my web host and on a local ampps installation and can’t get any PDF to process. I’ve tried multiple files. Here is what gets printed out on the page after I hit upload:

    File uploaded successfully! C:\Program Files (x86)\Ampps\www\wp/wp-content/uploads/2019/02/POMONA-3.pdf
    pdfimages -png C:\Program Files (x86)\Ampps\www\wp/wp-content/uploads/2019/02/POMONA-3.pdf C:\Program Files (x86)\Ampps\www\wp/wp-content/uploads/2019/02/POMONA-3_out/_images
    Ok
    pdf2txt.py -o C:\Program Files (x86)\Ampps\www\wp/wp-content/uploads/2019/02/POMONA-3_out/POMONA-3.txt C:\Program Files (x86)\Ampps\www\wp/wp-content/uploads/2019/02/POMONA-3.pdf
    Ok

    ( ! ) Warning: file_get_contents(C:\Program Files (x86)\Ampps\www\wp/wp-content/uploads/2019/02/POMONA-3_out/POMONA-3.txt): failed to open stream: No such file or directory in C:\Program Files (x86)\Ampps\www\wp\wp-content\plugins\pdf2post\pdf2post.php on line 516
    Call Stack
    # Time Memory Function Location
    1 0.0027 226496 {main}( ) …\edit.php:0
    2 0.0045 271448 require_once( ‘C:\Program Files (x86)\Ampps\www\wp\wp-admin\admin.php’ ) …\edit.php:10
    3 0.6093 20963232 do_action( ) …\admin.php:224
    4 0.6093 20963672 WP_Hook->do_action( ) …\plugin.php:453
    5 0.6093 20963720 WP_Hook->apply_filters( ) …\class-wp-hook.php:310
    6 0.6093 20964192 call_user_func_array:{C:\Program Files (x86)\Ampps\www\wp\wp-includes\class-wp-hook.php:286} ( ) …\class-wp-hook.php:286
    7 0.6093 20964440 PDF2Post->pdf2post_upload_page( ) …\class-wp-hook.php:286
    8 0.6093 20964656 PDF2Post->handle_pdf( ) …\pdf2post.php:48
    9 0.6507 20967928 PDF2Post->pdf2postFromAbsFile( ) …\pdf2post.php:367
    10 1.0311 20971296 file_get_contents ( )

    And here is the bit about libraries:
    The following libraries NEED to be installed on your server :
    ZipArchive Ok
    PDFMiner
    Python
    Not installed!
    pdfimages

    I’ve got python running and I’ve downloaded xpdf tools and added the path to it but it still doesn’t seem to want to find pdfimages. At least that’s what I assume part of the issue is since the other things appear to be installed (even though it only says OK next to ZipArchive).

    I’m not sure how to proceed but as yours is the only plugin that I’ve found that converts PDF to posts I really would like to find a way to make it work.

    Thanks for your help!

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author termel

    (@munger41)

    Hi,

    Thanks for your feedback.
    First the plugin has never been tested on a windows environnement, not on a local wordpress install, which seem to be the case, right?
    The problem could be linked to path, written differently on linux or windows.
    Do you have the possibility to run it on linux ?
    Else, can you please make an import and send us the log file under /logs/ ?
    Thanks

    Plugin Author termel

    (@munger41)

    I have an old laptop with ubuntu installed but nothing else is set up so I’d need to do port everything over to it or at least set up a blank WP and install PDF2post on it. I can try that but it’s not ideal as that machine has a dead battery and can’t be moved from it’s spot high on a shelf where I had it rigged up to act as the network point for a non-network printer and a few extra TB storage boxes before I updated my setup.

    Ampps runs Apache so I’m wondering if there isn’t a way to make it work as is. Of course I’d be happy for it to work on the Host Gator site that I ultimately want to post the converted PDF’s to so if you’ve got any ideas on what I need to do to get them to allow it to work that would be even better.

    I do have poppler installed. It doesn’t seem to have made any difference.

    Plugin Author termel

    (@munger41)

    ok so lets try on the windows machine : what is the output on the screen now when you try to convert ?
    can you send the log file over ?
    using our contact form : https://www.termel.fr/contact/

    Plugin Author termel

    (@munger41)

    the log file is the one appearing when you turn debug on inside wp-config.php file, under wp-content/debug.log

    I’ve sent it but here it is here as well:

    [05-Feb-2019 20:51:37 UTC] PHP Warning: file_get_contents(C:\Program Files (x86)\Ampps\www\wp/wp-content/uploads/2019/02/POMONA-6_out/POMONA-6.txt): failed to open stream: No such file or directory in C:\Program Files (x86)\Ampps\www\wp\wp-content\plugins\pdf2post\pdf2post.php on line 516

    [05-Feb-2019 20:51:37 UTC] PHP Stack trace:

    [05-Feb-2019 20:51:37 UTC] PHP 1. {main}() C:\Program Files (x86)\Ampps\www\wp\wp-admin\edit.php:0

    [05-Feb-2019 20:51:37 UTC] PHP 2. require_once() C:\Program Files (x86)\Ampps\www\wp\wp-admin\edit.php:10

    [05-Feb-2019 20:51:37 UTC] PHP 3. do_action() C:\Program Files (x86)\Ampps\www\wp\wp-admin\admin.php:224

    [05-Feb-2019 20:51:37 UTC] PHP 4. WP_Hook->do_action() C:\Program Files (x86)\Ampps\www\wp\wp-includes\plugin.php:453

    [05-Feb-2019 20:51:37 UTC] PHP 5. WP_Hook->apply_filters() C:\Program Files (x86)\Ampps\www\wp\wp-includes\class-wp-hook.php:310

    [05-Feb-2019 20:51:37 UTC] PHP 6. call_user_func_array:{C:\Program Files (x86)\Ampps\www\wp\wp-includes\class-wp-hook.php:286}() C:\Program Files (x86)\Ampps\www\wp\wp-includes\class-wp-hook.php:286

    [05-Feb-2019 20:51:37 UTC] PHP 7. PDF2Post->pdf2post_upload_page() C:\Program Files (x86)\Ampps\www\wp\wp-includes\class-wp-hook.php:286

    [05-Feb-2019 20:51:37 UTC] PHP 8. PDF2Post->handle_pdf() C:\Program Files (x86)\Ampps\www\wp\wp-content\plugins\pdf2post\pdf2post.php:48

    [05-Feb-2019 20:51:37 UTC] PHP 9. PDF2Post->pdf2postFromAbsFile() C:\Program Files (x86)\Ampps\www\wp\wp-content\plugins\pdf2post\pdf2post.php:367

    [05-Feb-2019 20:51:37 UTC] PHP 10. file_get_contents() C:\Program Files (x86)\Ampps\www\wp\wp-content\plugins\pdf2post\pdf2post.php:516

    Plugin Author termel

    (@munger41)

    Can you please upgrade to 2.1.4, test and send me your log file debug.log ?
    It won’t work on windows, but hopefully it’ll bring more clues on path…
    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Can’t get it to work’ is closed to new replies.