WordPress.org

Support

Support » How-To and Troubleshooting » Can’t get FORCE_SSL_ADMIN or FORCE_SSL_LOGIN to work

Can’t get FORCE_SSL_ADMIN or FORCE_SSL_LOGIN to work

  • I’m trying to get FORCE_SSL_ADMIN (or FORCE_SSL_LOGIN, for that matter) to work on my fresh install of WordPress 2.7. SSL is set up & working in Apache, and I’ve added the define statement in wp-config.php, but it doesn’t seem to make a difference, as it doesn’t force the login to go to SSH. What am I missing?

    Thanks,
    Kurt

Viewing 1 replies (of 1 total)
  • OK, I think I’ve got it figured out. I had to do the following two things before FORCE_SSL_ADMIN began to work:
    – moved the define statement to a place in wp-config.php BEFORE where it calls wp-settings.php
    – configured Apache’s SSL setup to include an alias that points to the non-SSL location of the wordpress directory

    For some reason, I still can’t get FORCE_SSL_LOGIN to work, but that’s not necessarily a problem, as we want the more secure option of FORCE_SSL_ADMIN anyhow.

    Kurt

Viewing 1 replies (of 1 total)
  • The topic ‘Can’t get FORCE_SSL_ADMIN or FORCE_SSL_LOGIN to work’ is closed to new replies.
Skip to toolbar