Support » Themes and Templates » Can't get custom header to work in twentyeleven

  • Resolved wperic


    I’m trying to upload a custom header for my twentyeleven WP, but it’s not working.

    Initially I was getting an error that WP couldn’t create the …wp-content/uploads/2011/09 folder, so I created that and gave it 777 permissions. Now I’m getting:
    “The uploaded file could not be moved to /var/www/html/wordpress/wp-content/uploads/2011/09.”

    So I manually moved the file to that folder. But now it doesn’t show up anywhere that I can choose it as the header image.

    I also moved it to …/wp-content/themes/twentyeleven/images/headers, where the default images are stored, but that doesn’t help me get a way to choose it either.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Well I checked permissions. I have 777 for everything from /var down, so that includes both the directory I’m trying to upload the file from and the directory I’m trying to upload it to (…wp-content/uploads/2011/09).

    I removed the copy I had manually placed there. I still get the same error message: “The uploaded file could not be moved to /var/www/html/wordpress/wp-content/uploads/2011/09.”

    What gives?

    I also tried removing the …wp-content/uploads/2011/09 and …wp-content/uploads/2011 and …wp-content/uploads directories I had created. Now I get the original error message again:

    “Unable to create directory /var/www/html/wordpress/wp-content/uploads/2011/09. Is its parent directory writable by the server?”

    As noted previously, wp-content definitely is 777. So why won’t this work?

    I get the same result (can’t create the directory) when I try to upload the image for twenty ten 1.2.

    So no one has any insight?
    Is this a bug?
    Is no one else having this problem? If not, what could be “wrong” with my setup? Everything else seems to be working fine.

    Well, here’s the info. Surprising that no one knows this:

    On the new and not very helpful Gnome3 desktop, I happened across some warnings from SELinux. A time-consuming search (there’s nothing about SELinux under the Fedora 15 documentation) finally informed me that Fedora 15 apparently installs SELinux by default (or surreptitiously). So it was keeping the upload of the new header from working. What a waste of time.

    I disabled SELinux ( and then the upload worked.

    Well, you’ve solved it by making your server less secure. Wouldn’t it have been better to have configured SELinux with the correct permissions (assuming we’re talking about a publicly avilable server here)?

    I would imagine that one reason nobody thought of the solution might have something to do with you not having mentioned that you were running Fedora 15. And even then, you would have had to get an answer from someone else running Fedora 15. This might be a long shot, because Fedora is a bleeding-edge distribution IIRC and not recommended for production use. You would probably be better with RHEL or CentOS (which is a rebuild of RHEL).



    This is my personal computer–just trying to learn WP and get my theme adjustments lined up before I set it up on my public server.

    I thought I had mentioned Fedora 15. I usually try to include the relevant info, but apparently had forgotten to do so in this case.


    No problem. Good luck with WP.

    I always used to use a local setup, but I don’t bother any more. I just set the site up on the server and then install the ‘Maintenance Mode’ plugin. Then I make a new or a child theme, activate it and play with it until I have everything as I want it.

    Then I deactivate maintenance mode.



    Thanks for the Maintenance Mode plugin tip. It’ll be useful down the road once I get better acquainted with WP.

    No problem. Good luck


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can't get custom header to work in twentyeleven’ is closed to new replies.