Support » Theme: Olsen Light » Can’t get comments box to show

  • Resolved borismoggy

    (@borismoggy)


    No matter what I do I can’t get my comments box to show on either pages or posts. Is there a trick with this theme?

    • This topic was modified 2 years, 6 months ago by  borismoggy.
Viewing 15 replies - 1 through 15 (of 15 total)
  • Hello!

    Edit the post and from the discussion meta box make sure “allow comments” is checked. If the meta box is not visible, enable it via the Screen Options panel on the top of the page. Have a look here https://codex.wordpress.org/Comments_in_WordPress#Enabling_Comments_on_Your_Site
    for more information on this.

    Hi…done that! Still no comment boxes 🙁

    Have you tried disabling your plugins?
    Perhaps you have one enabled that disables/interferes with comments.

    I shall check them all.

    Well that’s odd. The plugins I have are Akismet, Contact form, NextGen gallery, Smart Youtube pro, Sociable and Yoast seo.
    I deactivated them all and the comment boxes came back. Then I reactivated them one at a time and the comment boxes are still there.
    I don’t understand that.

    Hi there @borismoggy,
    Have you resolved this?

    Partly.
    For no reason now my full posts don’t display. I’ve been in settings cos I have never had summary only ticked, and it’s still not ticked, but I have to click ‘read more’ to see the comment box.
    Also it only displays on posts, not pages.
    Very confusing.

    • This reply was modified 2 years, 5 months ago by  borismoggy.

    Hi,
    While you are on the home page your comment box should not appear. You visitors must click on the “Read More” button to see comment box. This is the way it is meant to be.

    You will need to Check “Allow Comments” in the “Discussion” Section in your pages to see the comment box there.

    Yeah comments and discussion are checked.

    There’s another fault with this theme.

    Although I have a menu it is not added as a menu to the page. However it still displays. Bizarre right?

    Also I have a page which appears as a link on the menu, and within that page I link to a second page. That second page also appears on the menu lol
    The only way I can get rid of it is to add it as a child to the first page!!
    Surely this can’t be correct??

    Hi @borismoggy,
    have you selected a main menu Appearance->Menus under your menu settings (https://goo.gl/KUxLy3). Can you select one and let me know if the issue persists?

    Also for example in your contact page (http://www.thelastgreatadventure.com/contact-me/) I can see the comment box appear normally.
    Are you experiencing problems in an other page?

    • This reply was modified 2 years, 5 months ago by  Fotis.

    Sorry, thanks for your time but I got frustrated with this theme, there was lots of problems, all minor niggling ones but too many to put up with.
    I’ve now deleted it and got another which works flawlessly so far.
    Thanks for your help anyway.

    Sorry, see above

    Hi @borismoggy,
    could you please repeat your request?

    Hi
    Just read back to the top?
    It’s OK anyway I got a theme that works fine, thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can’t get comments box to show’ is closed to new replies.