WordPress.org

Support

Support » Themes and Templates » Can't get background image to appear.

Can't get background image to appear.

  • danny_getextra

    @danny_getextra

    I’m working on a childtheme and trying to add a new background image to the logo div.

    I’ve tried to add use the css command on a couple of div’s and it just says there’s a parse error. And the image doesn’t even appear on the page.

    I want to just get the image to appear. It is in the correct folder specified im just abit worried I’ve missed something out so wp isn’t targetting this particular folder for the images.

    Site URL http://79.170.40.241/tutoring4maths.co.uk/

Viewing 5 replies - 1 through 5 (of 5 total)
  • danny_getextra

    @danny_getextra

    here is the code i’ve editting. http://pastebin.com/raw.php?i=BJwPBWsh

    WPyogi

    @wpyogi

    Forum Moderator

    You are not currently actually using the child theme — looking at the stylesheet, it’s not set up correctly — the @import line does not go at the top of the page — but right below the commented header section.

    So review Child Themes and fix that, activate the child theme — make sure it is working by testing some obvious code in the child style.css file, and then try the background image again.

    danny_getextra

    @danny_getextra

    I understand what your saying. However I’ve tested other bits of code I was using the correct theme. Or else it wouldn’t let me set it up would it.

    I’ve reverted back to using the theme’s stylesheet itself and changing things on there.

    Thanks

    WPyogi

    @wpyogi

    Forum Moderator

    Did you try changing the new style.css file so it is set up correctly? You will create a LOT of grief for yourself by making changes in the regular style.css file. (There are posts on here all the time from people who loose a whole lot of work from not using a child theme…) At the very least, install a custom CSS plug-in.

    i_g_wright

    @i_g_wright

    Hi,

    I’m not sure what the problem is here, use the following CSS:

    #logo {
      width: 100%;
      margin: 35px 0;
      background: url('images/logo.png') transparent no-repeat;
    }

    From the pastebin example you posted you have a ` <- Remove that.

    * It also looks like you’ve now added the logo as a standard image?

    Anyway, hope this helps.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Can't get background image to appear.’ is closed to new replies.