WordPress.org

Support

Support » Themes and Templates » Can’t Get Any Themes to Work…Help!

Can’t Get Any Themes to Work…Help!

  • Hi…I follow the directions to the “T” and can’t get any themes to work.

    I have installed as instructed…and WordPress works fine but when I use a theme, like Mandigo, the style loads but the header image doesn’t. I am uploading via FTP to my site under the WP Content>Themes>Mandigo…and get the style format but no images.

    What’s interesting is EVERY theme I download, the headers never show up.

    Anyone experience this or have a suggestion???

    Thanks very much in advance!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Do you have a URL we could check out?

    Hi, I have some problemes with themes but, my probleme is that my theme doesn’t display well, I can’t see the categories, the archives and evene the blogroll….

    take a look here, http://zoonerap.awardspace.com

    I have also this message

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ” at line 1]
    SELECT cat_id, cat_name FROM

    help plz (the theme is from template monster)

    I don’t see your error – the default theme is displayed. Most likely you are trying to use a theme that is not compatible with WP 2.1.x.

    I paid for this theme, is there something I can do, to fix this probleme ?!!…

    Well, you ask back your money… or you can try to fix it:
    open the sidebar.php (hopefully there is something like that) and check for the Template Tags that were depracted in 2.1., and replace them with the new ones.

    I think that the function with the probleme is “Wp_get_archive”, but when I search in “tags editors” I found that its deprecated, and I could’nt find a new code…

    here is my “sidebar code”

    <div class="right_cell">
    <div class="search">
    					<div style="padding: 18 0 0 20">
    					<img src="<?php bloginfo('stylesheet_directory'); ?>/images/bull.gif" align="absmiddle">&nbsp;Search
    					<form method="get" id="searchform" action="<?php bloginfo('home'); ?>/">
    						<input type="text" style="width:130px"  name="s" id="s" value="<?php echo wp_specialchars($s, 1); ?>">&nbsp;<input type="image" src="<?php bloginfo('stylesheet_directory'); ?>/images/subm.gif"	style="border:0; background:none" value="submit" align="absmiddle">
    					</form>
    </div>
    
    				</div>
    				<div class="right_header">
    				Categories
    				</div>
    				<div class="right_content">
    				<ul style="margin-left:21px; margin-top:10px ">
    	<div class="cats"><?php wp_list_cats('sort_column=name&optioncount=1&hierarchical=0'); ?></div>
    
    				</div>
    				<br>
    				<div class="right_header">
    				archives
    				</div>
    				<div class="right_content">
    				<ul style="margin-left:21px; margin-top:10px ">
    					<?php wp_get_archives('type=monthly&format=custom&before=<li class="li2">&after'); ?>
    
    				</div>
    				<br>
    
    				<div class="right_content">
    				<?php
     $link_cats = $wpdb->get_results("SELECT cat_id, cat_name FROM $wpdb->linkcategories");
     foreach ($link_cats as $link_cat) {
     ?>
    
      <div class="right_header"><?php echo $link_cat->cat_name; ?></div>
      <div class="right_content">
       <ul style="margin-left:20">
       	<?php get_links($link_cat->cat_id, '<li class="li3">', '', '', FALSE, 'id', TRUE,
    TRUE, -1, TRUE); ?>
    
       </div>
    <br>
    
     <?php } ?>
     <div class="right_header">
    				meta
    				</div>
    				<div class="right_content">
    				<ul style="margin-left:21px;  ">
    	<?php wp_register('<li  class="li2">', ''); ?>
    	<li  class="li3"><?php wp_loginout(); ?>
    	<li class="li3"><a href="http://validator.w3.org/check/referer" title="This page validates as XHTML 1.0 Transitional">Valid XHTML</a>
    	<li class="li3"><a href="http://gmpg.org/xfn/">XFN</a>
    	<li class="li3"><a href="http://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress</a>
    	<?php wp_meta(); ?>
    
    				</div>
    
    				</div>
    
    			</div>
    		</div>
    	</div>

    I couldn’t identify the probleme to fixe it, Im not that expert in progrmaing …. can you help
    !: here is a screen shot of the template as it hase to be
    http://img95.imageshack.us/img95/4314/screenshotsa3.png

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t Get Any Themes to Work…Help!’ is closed to new replies.
Skip to toolbar