Support » Plugin: WordPress Popular Posts » cant get alignment on everything right

  • I’ve messed around with the css for a while now but can’t seem to figure it out. I can’t get everything to line up neatly to the left.
    Here’s the site – http://cnainfo.net/

    I just went back to using the default css here:

    .wpp-list { /* UL element */
    
    }
    
    	.wpp-list li { /* LI - post container */
    		overflow:auto;
    		display:block;
    		float:none;
    		clear:both;
    	}
    
    		/* title styles */
    		.wpp-post-title {
    		}
    
    		/* thumbnail styles */
    		.wpp-thumbnail {
    			display:inline;
    			float:left;
    			margin:0 5px 0 0;
    			border:none;
    		}
    
    		/* excerpt styles */
    		.wpp-excerpt {
    		}
    
    		/* Stats tag styles */
    		.post-stats {
    			font-size:9px;
    			font-weight:bold;
    		}
    
    			.wpp-comments {
    			}
    
    			.wpp-views {
    			}
    
    			.wpp-author {
    				font-style:italic;
    			}
    
    			.wpp-date {
    				display:block;
    				clear:right;
    			}
    
    		/* WP-PostRatings styles */
    		.wpp-rating {
    		}

    Thank you!

    http://wordpress.org/plugins/wordpress-popular-posts/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Hector Cabrera

    (@hcabrera)

    Hi there,

    Just checked your site and your HTML markup is not right. If you want to display your popular posts in an unordered list (UL), each popular item needs to be wrapped in LI tags. From the code, you just have the UL and a bunch of A tags together – which is why your list is displaying like that.

    I tried both
    <li>{thumb}{title}</li>
    and

    <li>{thumb}</li>
    <li>{title}</li>

    but didn’t have any luck

    Plugin Author Hector Cabrera

    (@hcabrera)

    Alright, try the following:

    .popular-posts ul { /* UL element */
    
    }
    
    	.popular-posts ul li { /* LI - post container */
    		overflow:auto;
    		display:block;
    		float:none;
    		clear:both;
    	}
    
    		/* title styles */
    		.wpp-post-title {
    		}
    
    		/* thumbnail styles */
    		.wpp-thumbnail {
    			display:inline;
    			float:left;
    			margin:0 5px 0 0;
    			border:none;
    		}
    
    		/* excerpt styles */
    		.wpp-excerpt {
    		}
    
    		/* Stats tag styles */
    		.post-stats {
    			font-size:9px;
    			font-weight:bold;
    		}
    
    			.wpp-comments {
    			}
    
    			.wpp-views {
    			}
    
    			.wpp-author {
    				font-style:italic;
    			}
    
    			.wpp-date {
    				display:block;
    				clear:right;
    			}
    
    		/* WP-PostRatings styles */
    		.wpp-rating {
    		}

    great that worked with one small change:
    `.wpp-thumbnail {
    align: left;
    `

    the only thing is now there’s a margin on the left i can’t get rid of.

    oh and for some reason the titles won’t style

    /* title styles */
    .wpp-post-title {
    text-decoration: none;
    }

    Im not sure if they’re being overridden by my theme

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘cant get alignment on everything right’ is closed to new replies.