Support » Fixing WordPress » Can’t get access to Plugin page in admin area

  • Resolved ben_griffith


    Hi to all,

    I have had some problems with my WP 2.7.1. for 4 weeks, and re-installed the version 2.3.3. which worked fine only it didn’t import my tags. So I deleted this version and re-installed 2.7.1. I don’t know why, I can’t get access to my Plugin page. The Plugin page as well as the “Installed”, “Edit” are redirected to the 404 page.
    The links go to wp-admin/plugins.php (e.g.) and all 3 plugin php files are definitively on the server (I checked and uploaded all 100x), but I have still the same problem.

    I have got a second blog (same address but with other name) and the plugins there are fine.

    Do you have any idea ?
    (I will not change to 2.8x, already 2.7.x is a doggy version).

    Thanks for all ideas

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have copied the wp-admin/plugin.files from my working wordpress. After I deleted all plugins. There were only the original akismet and hello.php! and I got access to the Install and Edit page. However, still the same problem, no access to the Plugin page itself.

    When I uploaded the akismet again, I got error message

    Warning: in_array() []: Wrong datatype for second argument in /home/sevenwin/public_html/blog/wp-admin/includes/plugin.php on line 233
    Editing akismet/akismet.php (inactive)

    Because I don’t need that akismet and I deleted it again.

    Afterwards, I uploaded my ardamis-dateme Plugin. I can edit it (Editing ardamis-dateme.php (inactive)), no error shown, however, I can’t activate it, because this Plugin page still doesn’t appear (redirected to 404)

    I hope you can help me

    Have you tried switching to the default theme and seeing if that fixes anything? Some themes have plugin-like functions that can break things in your admin section.

    If your theme is okay and the plugins are all deleted, then something may be missing or corrupted in your WordPress install. Try a manual reinstall (“upgrade” to the same version of WordPress) and try it out before activating any plugins. See:

    It works now, I deleted the ardamis-dateme again, chose the default theme and I got access.

    Now, I have that problem to get shown the function date: title

    I still do not understand why that other blog (for testing) in the same root works fine and the main blog doesn’t.

    Thanks for helping me

    And have solved last problem with

    global $db;
    $wp_query = "SELECT post_date, post_title, post_category, post_name FROM wp_posts WHERE post_type = 'POST' AND post_status ='publish' ORDER BY post_date DESC LIMIT 5";
    $result = mysql_query($wp_query) or die("Error: " . mysql_error());
    while($row = mysql_fetch_array( $result )) {
    $date_format = date("Y",strtotime($row["post_date"]));
    $post_date = date("m/d/Y",strtotime($row["post_date"]));
    $post_title = $row["post_title"];
    $post_name = $row["post_name"];
    $post_cat = $row["post_category"];
    echo '<a href="'.$date_format.'/'.$post_name.'/" title="'.$post_title.'">'.$post_date.' &ndash; '.$post_title.'</a>';


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t get access to Plugin page in admin area’ is closed to new replies.