Support » Multisite » [Resolved] Can't fix WordPress Multisite missing stylesheet/wp-admin issue

[Resolved] Can't fix WordPress Multisite missing stylesheet/wp-admin issue

  • Hello, I have been searching google like crazy and have of course read many help topics on this forum. However no matter what I try I cannot seem to fix this issue.

    So basically I have installed WordPress multisite on our GoDaddy server. Initially I didn’t get the option to chose between sub-domains or sub-directories, so after installation I had to go into WP-Config and set the subdomain_install to false…like so:

    define('SUBDOMAIN_INSTALL', false);

    After doing this my default wordpress site was working, along with a second site I set up under the directory /de/

    Now when I come to make a third site under the direcotry /fr/ for some reason it will not work. Which is very strange considering the /de/ site works fine.

    When I access the /fr/ site the stylesheet is blank, although the logo and twitter icons manage to show up. Not only that but I am unable to access the WP-ADMIN. I get the error “The page isn’t redirecting properly”

    I have tried multiple fixes that I have read, such as editing my .htaccess and wp-config. I even tried to edit the mod_rewrite/vhost configuration but I am unsure of how to do this on GoDaddy. I called them but they had no idea what I meant.

    If anybody can help I would be most grateful.

Viewing 15 replies - 1 through 15 (of 21 total)
  • What did you change your .htaccess to? You replaced the WP section and didn’t just add on to it right?

    Did you delete the TwentyEleven theme?

    Here is my .htaccess at the moment

    I have tried multiple adjustments based on things I have read here.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]


    # END WordPress

    I also figured something out about our server. Before I tried install multisite we already had the /de directory set up on the server, with it’s own installation. So now that I have set up the /de directory with our multisite I believe it’s not actually operating fully under multisite. Which means we have confused ourself lol.

    Even with this confusion Multisite is still not working because I still cannot get the /fr multisite to work.

    Ok I have managed to get into the WP-ADMIN after making some alterations to my .htaccess

    but now I still cannot get the theme to work on the new /fr site. bare in mind that I am using the Constellation blank theme which I have edited to our tastes.

    Your .htaccess is the one for subdomains.


    Grab the subfolder one.

    And again: Did you delete the TwentyEleven theme? (DON’T! I’m just asking if you did 🙂 )

    I didn’t delete it, but I disabled it. I will try out the subfolder .htaccess

    Disabled how?

    So long as the folder’s in the /wp-content/themes/ folder you should be okay. When it’s not, WP does funny things unless you change the default new theme.

    Do fix the .htaccess 🙂


    I have edited my .htaccess but now I get the following error on the browser when I try to go to http://www.mysite.com/fr/wp-admin

    The page isn’t redirecting properly

    The twenty eleven theme is definitely in the themes folder, on the root site.

    Nevermind I can get into the wp-admin now

    now the only problem is the stylesheet. It’s weird because it’s clearly reading the logo and the social icons, but the actual styling will not show.

    Check if ‘AllowOverride’ includes the setting ‘All’ in your httpd.conf file (ask your webhost if you don’t know what that means)

    That’s where the issue lies, because I am on a Godaddy shared hosting plan and they don’t give me access to the httpd.conf

    I tried calling them and the advisor had no clue what I was talking about, all he did was link me to their page showing you how to activate Multisite with WordPress.

    Well I know it can work on GoDaddy.

    Are you on Windows or Linux hosting?

    It’s running Linux.

    Would it work if i created my own httpd.conf file in the root folder?

    Alas no. It’s a server thing.

    Are you sure you set up the .htaccess correctly? Named it right and so on? No fucnky characters or extensions?

    I have checked again and the .htaccess is named correctly and inside it has the following:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Now I wish we decided on a VPS server instead 🙁

    Quite honestly, a VPS wouldn’t matter. If the images in posts are working, the .htaccess is most likely working. Is that the entire .htaccess? Nothing extra you’re not showing us?

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Can't fix WordPress Multisite missing stylesheet/wp-admin issue’ is closed to new replies.