Support » Fixing WordPress » Can’t fix the RSS slash problem

  • Can’t fix the problem with apostrophe’s being escaped in the syndication feeds. I’ve tried add_filters, but nothing seems to work.
    I’m getting emails from several people telling me my feeds are broken.
    What can I do?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Try this thread http://wordpress.org/support/3/5889
    It worked for me.

    Thanks trench. I did see that thread.
    Using the filters or grabbing those files, trench? I’m trying the filters in the feeds now, but hesitate on just grabbing a couple of files from CVS without knowing what other dependencies are associated with the files.

    Just checked with recent post — adding the filters does seem to work.
    add_filter(‘the_excerpt_rss’, ‘stripslashes’);
    add_filter(‘the_content’, ‘stripslashes’);
    To the syndication files.

    I added add_filter(‘comment_text’, ‘stripslashes’);
    to wp-includes/vars.php and it worked like a charm for me.

    Unfortunately, doesn’t do much for the syndication feeds…

    When I added the following to my htaccess:
    php_flag magic_quotes_gpc off
    php_flag magic_quotes_runtime off
    And tried to edit a comment, I got an error.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t fix the RSS slash problem’ is closed to new replies.