Support » Plugin: W3 Total Cache » Can’t find where I have zlib.output_compression enabled

  • Resolved Gil Sousa

    (@heckel)


    Hi all,

    I’ve getting a warning about zlib.output_compression being enabled, but I can’t figure out which plug-in is using / enabling it.

    I tried to deactivate zlib.output_compression via .htaccess, and that resulted in a server 500 error. So no luck there either.

    Here’s the warning:

    Either the PHP configuration, web server configuration or a script in the WordPress installation has zlib.output_compression enabled.
    Please locate and disable this setting to ensure proper HTTP compression behavior.

    Any idea how to fix this? I know I could easily just dismiss the message, but I’d rather have this fixed.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    Do you have gzip compression enabled in Performance>Browser Cache?

    Yes, it is enabled

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Are you using any plugins to enable zlib compression?

    I’m not sure about that to be honest. I have several plugins, the ones I suspect that might be using compression are:

    Smush
    WPSSO Core
    Yoast SEO

    I tried to disable the first one, but the warning message stayed there. The last two I want to keep them, so I didn’t try to disable them.

    Is there any way to find out exactly with plugins might be using zlib compression?

    I’m the author of WPSSO Core. I can confirm that WPSSO Core and its extensions do not use PHP’s zlib output compression, although WPSSO Core can call the gzencode() function when using the “SSO > Tools > Export Plugin and Add-on Settings” button to allow downloading a compressed settings file (*.json.gz).

    You may want to check your /etc/php.ini file and/or contact your hosting provider to make sure that setting has not been enable by default. Example:

    
    $ grep 'zlib\.output_compression =' /etc/php.ini
    zlib.output_compression = Off
    

    js.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.