Support » Fixing WordPress » Can’t find language dir in my custom theme directory.

  • ostrivn

    (@ostrivn)


    Hello, I am trying to find the language directory in my custom WordPress theme to translate some strings with PoEdit but I cannot find it… Please help!!! Thank you so much. I’ve attached a screenshot there above.
    Note: the custom theme I am using was created by me. I am new with WordPress so I have no idea which directories are required and which not… Please help me.
    P.D: This is not related to commercial products.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Radu Constantin

    (@raduconstantin)

    Hi,

    When working on a new theme, you need to generate that POT or PO file that’s inside the language folder. Here’s a very good article about what you need to do to generate the POT file for your theme: https://www.vivathemes.com/create-pot-file-theme-plugin/ I used this method more than 100 times and it worked very well every time. You can give this a try and let us know how it works.

    ostrivn

    (@ostrivn)

    Hello @raduconstantin, thank you so much for your reply Radu. I worked but not at the same time… I’ll give a screenshot of what cmd shows me, hope you can help me up!! Thank you again:)

    ScreenShot: https://yadi.sk/i/BxtUefKApvB2aA

    • This reply was modified 9 months ago by  ostrivn.
    Radu Constantin

    (@raduconstantin)

    Hi,

    Can you tell me what’s the error? Or maybe attach the POT file that’s generated too (so I can have a look at it)?

    ostrivn

    (@ostrivn)

    Moderator stephencottontail

    (@stephencottontail)

    msguniq is part of GNU gettext. I found this with a quick Google search, but I’m not familiar with Windows Powershell so I’m not sure if it’s going to be useful: https://github.com/vslavik/gettext-tools-windows

    Radu Constantin

    (@raduconstantin)

    Hi,

    You’re on the right track with the POT file. Have you tried to open PoEdit first and then use the File → Open option to check the POT file? Basically, the error that you have is due to a text duplicate. You need to click Details and see in which line is this duplicate string. Once you identified it, open the POT file using a text editor, remove the duplicate string (just simply delete it like a simple text), save the changes and try again to open it with PoEdit. Just give this a try and let me know how it goes.

    ostrivn

    (@ostrivn)

    YEAP, you are right. It works!!! Thank you so much!!!
    Just one more question. I am using WPGlobus plugin to translate my website, how do I switch to the correct language?) I mean to see PoEdit changes with WPGlobus translations… Thank You!!!!

    Hello again, I opened it but I can’t see the content of my WordPress theme, I mean buttons, texts etc. Could the “msguniq” be the cause of this?
    Thank you!
    Here is the screenshot: https://yadi.sk/i/eV_MJgke0ebQ4Q

    Hi,

    I never used WPGlobus to create a multilanguage website. This is the first time to hear about it. Is there any chance that you could send me a link to a GitHub repository or maybe a theme archive? This way I could generated the POT file for you with no problem 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Can’t find language dir in my custom theme directory.’ is closed to new replies.