Support » Plugin: WP-Members Membership Plugin » Can’t export my users (error message instead)

  • Resolved gbenoit

    (@gbenoit)


    Hi all,

    I want to export my users. When I click on “Export all” inside the User page, I receive this error message :

    Parse error: syntax error, unexpected ‘[‘ in /usr/home/mw2p8plbny/www/htdocs/wordpress/wp-content/plugins/wp-members/admin/user-export.php on line 125

    When I disable the “WP Members” plugin, the Export button inside Users disappears.
    Can someone help me ?

    Kind regards

    Benoit

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Chad Butler

    (@cbutlerjr)

    The bracket indicated in your error (“[“) is where the initial array of fields for export is defined. This is a PHP 5.4 and later syntax, so it may be that you’re running a version of PHP earlier than 5.4. If so, you need to update PHP because WP’s minimum requirement is 5.6.

    Hi Chad,

    Thanks a lot. Indeed my WP page tells me that I need to update my PHP version, but it doesn’t show me any link where I can do this. Then it also tells me that I can update my WordPress version to 5.2.1 but it requires PHP 5.6.20 or higher which I don’t have so I can’t update WordPress either…

    Can anyone please let me know where to go to upgrade my PHP version ?

    Kind regards,

    Benoit

    Sorry, I find the answer to my above question. I need to update my PHP through the hosting company’s control panel page. (I am novice in the Internet world, but finding that on WP, some items like plugins or WP version can be updated on WP and other like PHP cannot seems to me very unconvenient, so a service intended to amateurs).

    Then I solve the export user issue. Indeed I needed to update my PHP version. Chad, thanks again for giving the solution, hard to find alone for an amateur.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t export my users (error message instead)’ is closed to new replies.