WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Can't exclude a Page

[Resolved] Can't exclude a Page

  • doremifasolatido
    Member

    @doremifasolatido

    Hi.

    In widget field “Pages to Exclude, Comma Separated:” I’ve added the page ID, still the page keeps showing in the website widget. Everything else works fine.

    I don’t know if it has to do it’s a “grand child” page.
    Parent Page
    – Child Page
    — Grand Children Page

    This is how it works: Only when on “Child” page I see all “Grand Children” pages.

    This is how I want it to work : Only when on “Child” page I see all “Grand Children” pages EXCEPT this particular “Grand Children” page.

    http://wordpress.org/extend/plugins/advanced-sidebar-menu/

Viewing 7 replies - 1 through 7 (of 7 total)
  • doremifasolatido
    Member

    @doremifasolatido

    Checked “Legacy Mode: (use pre 4.0 structure and css)” in widget and it works now.

    Plugin Author Mat Lipe
    Participant

    @mat-lipe

    Hi doremifasolatido,

    Thank you for pointing out this bug. I have released an update which should take care of it.

    Please give it a try and let me know if it works better now.
    Version 4.3.4.

    Thanks

    doremifasolatido
    Member

    @doremifasolatido

    New version works without checking “Legacy Mode..” box!

    Thank You!

    Just following up on this thread, I’m using version 3.5.0 and exclude doesn’t work, it doesn’t say whether you’re supposed to enter a page ID or permalink name.

    Is 3.5.0 known to not work for exclude, works great otherwise. If I have to upgrade to get exclude to work are there any known upgrade issues.

    Thanks…

    Plugin Author Mat Lipe
    Participant

    @mat-lipe

    Hi mcbryant,

    The latest version of this plugin is known to work with page exclusions. The excluding currently only works with the page ID.

    There are no known issues with upgrading. The structured output has changed a little since 3.5.0 so I have added a legacy mode checkbox which will give you the pre version 4 structure just in case you have some styling, etc which requires the old structure.

    Hope this helps!

    depictionary
    Member

    @depictionary

    I’m trying to display JUST the grandchildren in the menu. Not the parent or children. How do I exclude the “aunts” and “uncles” and direct parent of the tertiary level navigation? It’s not working for me to exclude via page slugs within the field on the widget options as well. Thanks!

    Plugin Author Mat Lipe
    Participant

    @mat-lipe

    Hi depictionary,

    The excluding currently only works with the page ID.

    There is currently no built in way to exclude the child page and display the grandchild pages only. You can probably accomplish this using a template override. See http://matlipe.com/advanced-sidebar-menu/developer-docs/

    HTH

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Can't exclude a Page’ is closed to new replies.