Support » Installing WordPress » Can’t even ftp the wordpress files to server??

  • gaspeer


    Hi, I’d really like to install 1.5. I have used 3 different ftp clients trying to upload all the unzipped 1.5 folders and files to my web site. Seems my web host can’t do passive ftp. So when I set the ftp client to do active mode, I can get about 30-50 percent of the wordpress 1.5 folders/files to upload. Then all at once, I start getting 500 errors, then the ftp client switches to passive mode and I begin getting more errors, until I get a boat load of “critical errors” and the ftp upload simply stops.

    I’ve sent a dozen messages to my web host folks. They have tried a ton of ideas and finally switched me to a different server. Still the problems continue.

    I have NEVER had this problem uploading via ftp before, so I don’t know why it’s happening when I try it with wordpress. And, no, I didn’t have wordpress 1.2.2 installed. This is a fresh install.

    Any ideas??

    Gary Speer

Viewing 6 replies - 1 through 6 (of 6 total)
  • mcangeli


    What ftp client are you using??

    Also, is your server *nix based or Windows?

    What platform is your desktop?



    I used ws_ftp for my site, and it works fine… Hmmm.

    Some web hosts, ‘passive’ in the ftp program has to be off, otherwise it wont accept files for upload.

    I forget where that is offhand in ws_ftp, but you might check it.

    What ever it is set to now, click it to the other setting and try your upload again.

    Also, check if the site you are uploading to requires a different format than http://ftp.hostname as some require ftp@hostname

    You could also ask them for the ip address of their ftp server. Maybe the name bit isn’t working properly.

    wordpress files should have no affect on this.

    Does your web server, them not you, have php files blocked from upload ?

    I know the web server I use has exe file uploads blocked.

    I hope some of that helps.



    I upload from a Win98se desktop to a bsd server. No problems.

    You might set ws_ftp, or what ever ftp program you use, to ‘auto detect’ for server type. It may be the server type you pick to upload to is incorrect.



    Thanks for the good responses. Alas, I’ve tried everything you folks have suggested. Neither I nor my web host can figure out what the problem is??

    BTW — it’s a linux web host; I have tried using ws_ftp pro and filezilla and ftp Navigator. And even though I set them all to work “active mode” as my web host says it’s required — once I start getting error messages, the softwar automatically shifts to passive mode. I can’t seem to find a way to override that switch to passive, even though I have active mode set.

    Big puzzle, eh?

    Gary Speer




    Try uploading one folder at a time. Start with just the ap-admin folder first. It maybe a connection overload problem.

    OR, if you can, see what dir it starts erroring on, and then try uploading just that dir by itself and see if it continues.





    Thanks for the suggestion, Tg. It seems simple enough that I probably should have thought of it myself.

    I simply made certain my ftp client WAS set to “active mode” as the webhost required, then started uploading in small gulps — a folder, half a dozen files, etc.

    Worked great. I then ran “install.php” and there I am.

    Now, if I only had something to say (??) I’d be blogging. (grin)

    Gary Speer

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can’t even ftp the wordpress files to server??’ is closed to new replies.