Support » Plugin: WooCommerce Square » Can’t enter credit card info online site with Square

  • Resolved jbwpdw19

    (@jbwpdw19)


    Hi!

    I’m having an on and off issue with Square gateway online payment. Since last week, everything was working fine, but now every day (on/off problem) people can’t enter their credit card infos.

    My client is not very happy 🙁

    http://secourismesaglac.com

    Can you help me?

    Thank you,
    Josee

    The page I need help with: [log in to see the link]

Viewing 14 replies - 16 through 29 (of 29 total)
  • I’m experiencing the same issue with the plugin. Customers are not able to enter card information

    I rolled back the WooCommerce Square plugin to verson 2.1.1 and that fixed it for now.

    Hi! Yes, if you roll back to version 2.1.1 the issue is fixed 🙂 and I hope that the development team is working on solving this problem, once and for all.

    Same issue (ver. 2.1.3), same fix (backrev to 2.1.1). Thank you all for providing the answer. 🙂

    I was having a similar issue but only android phones?
    only first-time visitors were having an issue, If they refresh the page then they could enter it? I didn’t want to roll back plugin because updating it fixed other issues. So found that I was Cashing the checkout page through Cloudflare- I made a rule not to cache checkout page it seems to have fixed it..
    Not sure if regular cache plugin would cause the same issue.

    Hope this may help someone with the same issue
    Regards
    J

    I am also having this issue. The payment form is visible, but I am unable to focus any of the form inputs in the checkout.

    am I having the same issue, however mine is just on the mobile version of my site.

    can you please help?

    After some troubleshooting, I found that the issue I was experiencing was due to an error being thrown by the WooCommerce Facebook plugin. Once I deactivated that plugin, this error went away.

    I have the same error with others. Credit cards fields are not showing up on the checkout page I installed Dokan SquareUp Woocommerce Dokan SquareUp v. 1.0.1. The site https://vision4.art/ is using woocommerce v. 3.8.1 and dokan v. 3.0.3 (integrated with dokan business pro v. 3.0.2) as primary store setup. Hope someone can resolve this issue, thanks

    Can someone confirm this, it says square payment is only working on the ff. countries ( Puerto Rico, Guam, the U.S. Virgin Islands, American Samoa, and Northern Mariana Islands). Because the local store address set on squareup portal was on switzerland and I’m testing it here in PH. Please someone help, thanks

    Hi @madeincosmos,

    I’m experiencing the same issue. I have attached the required info needed to diagnose the issue.

    https://www.whatsmybrowser.org/b/YCZS9

    There are no error shown on console view. Please advise.

    ankitpatel007

    (@ankitpatel007)

    I have an issue with square payment plugin. i am testing in sandbox mode. during checkout i am unable to edit card details, can’t able to enter details in field.
    Here are my website link:https://www.whatsmybrowser.org/b/GJHIR
    the error i found on console:https://snipboard.io/lJxC75.jpg.

    Please help me. this is very urgent

    I just wanted to post that I, too, had the same problem. Another user posted to disable the caching of the checkout page in the Autoptimize plugin… Unchecked the box and cleared the cache – problem immediately fixed.

    It seems like some other might be having different problems… the symptoms for me were that the option showed up on checkout, fields for square were present, but clicking on them did nothing and the customer could not enter their information.

    Admittedly, I didn’t actually read them, but it may be in the author’s best interest, if not already there, to add a bullet point to the release notes noting the compatibility issue with this option in Autoptimize.

    Hello
    I am using the latest version of the plugin. I am from Bangladesh but my client from the USA is also seeing the same issue.

    #Can not enter credit card info, fields look like disable.
    https://www.whatsmybrowser.org/b/LRUPP

    Console Screenshot:
    http://prntscr.com/wgilwi

    Would you please help me to fix the issue?
    Thanks

Viewing 14 replies - 16 through 29 (of 29 total)
  • You must be logged in to reply to this topic.