Support » Plugin: Yoast SEO » Can't enable social meta data in Yoast SEO

  • Resolved sardattack

    (@sardattack)


    Hi,
    I’m trying to enable social meta data for one of our customer’s website using Yoast SEO, but I’m facing a really strange issue: I clic Enable button, and after saving changes, the option comes back to the disabled status. This happens for every social network… I tried with Facebook, Twitter and Google+ and experienced the same problem. If I modify other options, it seems everything works fine.

    I verified all Yoast SEO plugin configuration and couldn’t find anything that seems wrong. Searching in Google or in the support forum didn’t help me.

    Have anyone been in trouble with a similar issue, or can help me on finding the right way to investigate the problem?

    Thanks!

    Matteo

    https://wordpress.org/plugins/wordpress-seo/

Viewing 6 replies - 1 through 6 (of 6 total)
  • sardattack, what’s the version of yoast you are using?

    Hello Sami, it was version 3.1.1. I’ve updated to version 3.1.2 today but unfortunately I’m experiencing the same issue. Looking Apache server logs isn’t helpful too, I’m not able to find anything I can refer to this issue.

    Hi sardattack, I have tried the yoast 3.1.2 on wordpress 4.4.2 and does not found any issue similar like yours.

    I have tried yoast previous version as well but that works fine for me.

    Can you tell me that how i can produce this issue or can you provide me the environment where i can take a look of it?

    Thanks,
    Sami

    Hi Sami,
    thank you very much for your help, I really appreciate it!

    I’m fortunately experiencing this issue only in one website, so what you tell me isn’t a surprise. I wasn’t able to produce this issue anywhere else too.
    I think it may depends on some conflict with another plugin, or maybe with the theme, but I’m in trouble finding where to investigate.

    The website I’m talking about is http://www.limmi.it, based on a commercial theme (Agrofield) with only some CSS styling and layout customizations. Nothing that could be related to such an issue, in my opinion.
    Wordpress, every plugin and the theme are updated to the last version available.

    Tell me which information you’d find useful to understand where to investigate, I’ll give you.

    Thanks again for your help!

    Matteo

    Hi sardattack, so this is a rare case issue.

    First suggestion is to deactivate all the plugins from your site and then check this issue if this issue a cause of conflicts with some plugin so, it works for you after deactivating all the plugins.

    And if plugins won’t help you then change your theme, use some other theme and check again the issue.

    If the above solution does not work for you so i would like to take a look of your settings. so, if you can provide me the dashboard access then it would be great and i’ll check this once from the dashboard?

    Otherwise, the only option left which is to hack the Yoast and fix your issue. If you like so, i’ll also help you in hacking the Yoast. But, first try by deactivating plugins and changing the theme because if that works for you so, you don’t need do anything else.

    Hope you got the solution soon 🙂

    Thanks,
    Sami

    Hi Sami,
    I’ll try deactivating all plugins as you suggested.

    If this won’t be helpful I’ll try to use another theme too. I really hope this won’t be the case, because changing the theme isn’t a way our customer will consider to follow.

    If none of these test will work, I can give you dashboard access.

    I’ll let you know how it goes 🙂

    Thank you very much for your support!

    Matteo

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can't enable social meta data in Yoast SEO’ is closed to new replies.