WordPress.org

Support

Support » Localhost Installs » Can't enable rewrite mode for permalink

Can't enable rewrite mode for permalink

  • 9tontruck
    Member

    @9tontruck

    I am setting up a wordpress page on an ubuntu server with Apache/2.4.6 (Ubuntu).

    Here is what I did:

    I enabled rewrite mod with
    : a2enmod rewrite
    Changed “AllowOverride None” to “AllowOverride All” in apache2.conf
    :vi /etc/apache2/apache2.conf

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    Require all denied
    </Directory>
    
    <Directory /usr/share>
    AllowOverride All
    Require all granted
    </Directory>
    
    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

    Restarted apache2 server
    : sudo service apache2 restart

    But I am still getting 404 error on my perma link wordpress page..

    What Am I missing?

Viewing 2 replies - 1 through 2 (of 2 total)
  • karpstrucking
    Member

    @karpstrucking

    What does the .htaccess file in the WP root folder look like?

    RossMitchell
    Participant

    @rossmitchell

    An easy trap to fall into, is to not have .htaccess writable by the web hosting application. Unless apache can write to .htaccess it cannot enable permalinks.
    Make sure .htaccess is mode 777
    Once you have the settings there you can restrict the permissions, this is not so important on your localhost, but is significant on a hosted website.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Can't enable rewrite mode for permalink’ is closed to new replies.