Support » Plugin: SiteGround Optimizer » Can’t Enable Full-Page Caching

  • Resolved ebiznation

    (@ebiznation)


    Under the SiteGround Optimizer – Caching settings when I try to connect “Cloudflare Full Page Caching” I get an error “Please provide valid API key & email address” but my API & Email are correct.

    The popup does say “Your Cloudflare account may have page rules set that might affect the work of our integration.”

    What page rules are they talking about?

    Should I really care about this setting and leave it not connected to Cloudflare?

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Elena Chavdarova

    (@elenachavdarova)

    Hello @ebiznation,

    Double-check if you are using the same Cloudflare account which is connected in SiteTools and get the API Key from it.

    In case the connection still can not be established, please include the website domain in your next reply so we can check the case as well.

    As for the notice – it is a warning to notify you that any existing page rules set in Cloudflare will be lost during the Cloudflare Full Page cache activation as they will be replaced by the Cloudflare Worker instead.

    Best Regards,
    Elena

    Thread Starter ebiznation

    (@ebiznation)

    Hi Elena,

    I only see one email address the same one I used when I signed up for Siteground.

    Inside the Siteground dashboard under Cloudflare, it says ‘ACTIVE”. Scroll to the bottom it shows the same email.

    I’ve had this Cloudflare account before moving to Siteground but made sure all my domains were removed before activating it with Siteground.

    Here’s my domain. ebiznation.com

    I also tried to connect another domain to Cloudflare and when I click on “COMPLETE ACTIVATION” I get this warning

    “Failed to activate Cloudflare for dfyleadmagnets.com. Cloudflare API returned error(s): Unknown X-Auth-Key or X-Auth-Email.”

    But it was added to Cloudflare.

    I’m sorry but I’ve never had these problems with connecting to Cloudflare before. I’ve always just pointed the domain and I was done.

    Plugin Author Elena Chavdarova

    (@elenachavdarova)

    The plugin Cloudflare connection request is working as expected. It appears there is something specific here, related to your domain setup and settings.

    I suggest you to reach out SiteGround support for further assistance on the matter.

    Best Regards,
    Elena

    Thread Starter ebiznation

    (@ebiznation)

    Thank you,

    I’ll contact support.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.