Support » Networking WordPress » Can’t embed videos after upgrade to Multisite

  • All of my users with the Editor role used to be able to paste embeds into new posts just fine. After the upgrade to Multiuser, their embeds get stripped away like they were a contributor or Author role. How do I fix this so their embeds don’t get stripped?

Viewing 15 replies - 1 through 15 (of 21 total)
  • That’s a security feature of MU.

    Not sure if this plugin works with 3.0, but you might want to try:
    http://wordpress.org/extend/plugins/unfiltered-mu/

    There is more about that here:
    http://www.clickonf5.org/wordpress-mu/youtube-other-video-not-embedding-wordpress-mu/5820

    Anyone? I know I can’t be the only one having this problem.

    I kinda feel ignored 😉 – Is my reply hidden because it contains two links?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    @tordavis – try the plugin mentioned above.

    Thanks guys! Implementing it now.

    tried two plugins and still embeds not working. They work for me, the administrator but no longer work for Editors. I made someone an editor and they still weren’t able to embed. this is weird.

    The only way it will work is by making someone a super admin.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    .. and you don’t wanna do that…

    What about the built in embeds?

    I have specific parameters for my Blip.tv embeds. There’s GOT to be another way.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    whipping up a quick plugin to allow it? that’s what we did with mu.

    We too are having this issue as well with our 30+ blog network. Upgraded to WP 3.0 yesterday and blog/site administrators who in 2.9 could add video embed code to their posts are not allowed to, it strips out the code. As a Super Admin I have the ability to add embed code all day long, unfortunately with 30+ blogs that’s exactly what I will be doing if this is not resolved.

    Anyone have any ideas? Did they strip out permissions from site/blog admins that can be changed by super admins giving them that capability. Really need some help with this.

    I wonder if one of the various members plugins could be used to grant this access. But yeah, one of the (major) downsides to MS/MU 🙁

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    and blog/site administrators who in 2.9 could add video embed code to their posts are not allowed to, it strips out the code.

    So what did you have in place in 2.9 for them to do that?

    In 2.9, by default, it stripped code. You had to allow it, so if you hacked the kses.php file, then it got overwritten on upgrade.

    It may have been a hack.

    Unfortunately I did not build the network, I just maintain it. The developers have been made aware of this issue, yet they are a little slow to react.

    Initially I was wondering if there was a simple on/off switch that got turned off in the upgrade, but it appears that you may be onto something. Our blog network is rather custom so it would not surprise me that functionality that was important to us upon build, were not native to any version of MU at the time and required mountains of hacks and programing to achieve our results.

    In 2.9 it worked for me and anyone with the role of Editor. It was never an issue. I know it has something to do with WP3.0 MU. None of the MU plugins work though. There’s got to be something in the database that can be changed to turn it on.

    [Edit] Added the role manager plugin and Editor Role has unfiltered_html checked. This is a bug in WP3.0. Something that is going to have to be fixed. Until then, Vipers will do.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Can’t embed videos after upgrade to Multisite’ is closed to new replies.