Can't Embed Video (7 posts)

  1. tworivers
    Posted 4 years ago #

    I just got my wordpres site online, I am new to everything wordpres so I was delighted when I figured out how to install it and now it is up and running. One of the main things I want to be able to do is incorporate video's on my blog. I would like to keep videos on my google drive and then stream them from there.

    I have tried JW player but it doesn't work, the black box where the video should show just blinks black. (I was linking this to the public folder on my dropbox account)

    I have tried using the code from google to embed it in my player. but nothing happens.

    Not sure what I am doing wrong.

    Any help with streaming video would be greatly appreciated.

  2. Johnb81
    Posted 4 years ago #

    Did you try to use a Video streaming plugin such as http://wordpress.org/extend/plugins/stream-video-player/?

  3. tworivers
    Posted 4 years ago #

    These are some of the ones that I have tried.

    Blubrry PowerPress
    Embedded Video
    JW Player Plugin for WordPress
    Stream Video Player

    I went back and tested Stream Video Player to stream a random youtube video I like. But it still doesn't show anything in the post.
    Here is the link to my site:

    there should be a youtube video (http://www.youtube.com/watch?v=z1nJrioKNvI) showing on the page but it isn't working.

    Are there any minimum requirements that I need on my site for streaming video to work? or is there something I need to install on the server to make video work?


  4. Saad Hassan123456789
    Posted 4 years ago #

    u may try the old embed code insted of iframe for the plugins or without plugins

  5. tworivers
    Posted 4 years ago #

    thanks for the input but I don't know hardly anything about code so not sure what you mean about the old code.


  6. Johnb81
    Posted 4 years ago #

    you can read more about it here:


    Quick a good read as it is not just about videos.

  7. tworivers
    Posted 4 years ago #

    Thanks for the link,

    Finally figured out that the problem was with the theme now I changed the theme and it is working.

Topic Closed

This topic has been closed to new replies.

About this Topic