Support » Fixing WordPress » Can't Edit Widgets After 3.5 Update

  • After updating to WordPress 3.5, I’m unable to edit any widgets in the dashboard. I deactivated every plug-in, cleared cache, changed theme to the standard template, and nothing has worked. Any direction would be great!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Moderator t-p


    -Have you tried manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory. Read the Manual Update directions first!

    Make sure you backup everything (including your database) before doing any actions, just in case.

    Also try adding:

    define( 'CONCATENATE_SCRIPTS', false );

    to your wp-config.php file, (IF disabling all of your plugins checking if it’s a plugin that’s causing it) doesn’t work.

    Sadly neither of those things worked for me. Not sure why. Super frustrating!

    Moderator t-p


    what theme are you working with?

    I tried it with the Twenty Twelve default just to test it out but that didn’t work so I switch back to my main theme, “Bloc” by YooTheme.

    Moderator t-p


    Is that a commercial theme? If it is, you want to contact the vendor.

    Actually looking through my FTP, I realized I can’t find “wp-config.php,” only “wp-config.sample.php” in the root. Is that something I need to create? Could that be causing issues?

    Hello jmleavey,

    No your wp-config.php is not the problem, at least not for your widgets not working. I believe it’s a theme related issue.

    I have the same problem with one of my sites that uses the ‘Twenty Eleven’ theme. When I upgraded that site to 3.5 I can’t edit the widgets anymore.

    Other sites I have that do not use the Twenty eleven theme do not have that problem and editing the widgets works just fine. That’s why I think it is WP3.5 and theme related.

    How to fix that?

    I wish I had the answer, other than picking a different theme and redesigning my entire site layout… (I hope not).

    Anyone else has an answer?


    Thanks for all the help guys. Sadly I haven’t made any progress on this. I’m just not sure it’s theme related since I’ve tried several themes and they all have the issue. I’m close to giving up because I think this is way over my head.

    Moderator t-p


    have you contacted your hosting provider?

    I have the same issue … after upgrading to 3.5 the widgets are no longer editable .. tried deactivating all plugins but it is an update issue .. hope that its solved soon… not updating any more sites until they find the bug.

    Moderator t-p


    @neilson64, please start your own thread. That way you will get more responses to your specific issue.

    I am having the same problem. I looked on this forum topic,

    and it says

    On some hosting environments, aggressive settings for the “mod_pagespeed” addon can break the javascript code and cause scripts to not be able to function. This can cause many problems, such as widgets not working, menus not being draggable, the customizer not working, or the media screens not being available.

    To fix the issue, you will need to disable mod_pagespeed, or adjust its settings to not take effect in the wp-admin directories. You may need to ask your hosting service for help on how to do this.

    I haven’t done this yet, and am not sure how to, but I am about to try to figure it out.

    I have the same problem – amongst others


    Do any of you have BulletProof Security installed or had it installed at one time? I do and when I updated it, everything worked fine.

    Check out this bug alert found at thanks to negs:

    BulletProof Security –

    Update to the latest version (.47.7) to fix issues with javascript functionality in WordPress not working correctly.
    Note: You can still have this problem if you have *ever* used the BulletProof Security in the past, even if you have removed it. If you are experiencing problems with menus and widgets and the editor and similar not working, and you have ever used BulletProof Security, even if you’re not using it anymore, then look for an .htaccess file in the /wp-admin directory, and delete it if it is there.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can't Edit Widgets After 3.5 Update’ is closed to new replies.