Support » Fixing WordPress » Can’t edit widgets

  • I just upgraded from 2.5.1 (I think) to 2.9.2. The update went okay for the most part, but the Widget page doesn’t work. On the left I have a palette of available widgets and on the right are the widgets I have on my sidebar but there is no way to adjust settings and the widgets are non-dragable.

    At this point I don’t need to remove or add widgets, but for some reason my tag cloud is not styled properly (now left-aligned instead of centred; and tags break across lines which is bad because they’re all names) and I’d like to fix it.

    Can anyone help?

Viewing 8 replies - 1 through 8 (of 8 total)
  • For the secondary problem, I now seem to recall making changes manually to the PHP to get it to look how I wanted it to, so I’m going to see if I can track down where I might have done that, but the main problem still exists. Thanks for any assistance.

    I’m experiencing this as well. I’ve been running 2.9.2 since about a week from the release. It didn’t happen right away. I edited widgets on my site as recently as a week or so ago. Now I can’t.

    Interestingly, the pull down menus in the admin section have stopped working as well. All other things seem fine, but these two peculiar issues have come out of nowhere. I haven’t installed any new plugins or introduced anything new to my server in months.

    Any insight is much appreciated 🙂

    Just to clarify…I’ve been through the forums a bit, and it seems this problem keeps coming up. Not even just this version of WP.

    I’ve deactivated all plugins, and that doesn’t fix it.

    Another update….I’ve replaced all wordpress files with a fresh copy from Still no love. Widgets are still frozen. What the heck? My other WP sites…on the same web host…are fine. I have to admit I’m stumped on this one so far.

    I deleted my theme and reinstalled the SAME theme, and now everything works. Why did that fix it? I’ll be honest…I have no friggin idea! Deleting and reinstalling is always a viable fix. It’s just hard sometimes to know WHAT needs deleted and reinstalled!

    I’m surprised no responses from the community so far, especially since this is an issue affecting many users. this thread is over a week old 🙂

    Where are the experts on this problem? There are many threads on this going back several versions. Running 2.9.2, I was able to edit widgets until a couple of days ago. I have reset permissions on both widgets.php files (in wp-includes and wp-admin), and I have no plugins currently activated. I’m setting up a site that has to launch in a few days, and an RSS feed (WP default widget) that can’t find the feed, and I can’t remove it or fix the url. Are there other relevent core files that might need permissions opened? Anyone?

    Update – I have found that this is definitely a javascript problem. I have a conflict with a css animation script call in my theme that didn’t work on WP, so I commented out line 120 in the script-loader.php. This worked to get my animations working on the site, but it is what caused my widgets panel (and also my visual editor) to not work. Reset it, and the dashboard functions work fine. I’m hoping someone can help me figure out a way to have both the dashboard and my jquery-based animations work concurrently.

    I have the same problem. Widgets are frozen in the admin area. I can’t expand them to edit their settings. What the?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Can’t edit widgets’ is closed to new replies.