Support » Fixing WordPress » Can’t edit website

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator t-p

    (@t-p)

    Blank white page: A blank white page means that PHP is crashing. This problem can be caused by a variety of issues, including: (1) Bad theme (2) Bad plugin (3) Bad install/upgrade (4) you exhausted the memory limit (5) It could also mean that there is an issue with your web hosting server.
    – 1 and 2 are more common (typically due to a function conflict introduced by a plugin or theme).
    – Since the problem can be caused by any number of things, check the error logs on your server for a more specific error message. If you need help locating them, ask your hosting provider to help you with that.
    – If you cannot find error logs or if you don’t find any helpful info in them, try Enabling debugging
    – Also, try reviewing this useful Codex: http://codex.wordpress.org/Common_WordPress_Errors#The_White_Screen_of_Death

    This is really helpful. I have:
    * My hosting provider (Bluehost) claims no errors showing on log.
    * I have installed the Health Check:
    — It recommended PHP of 7.2 (or higher). Done.
    — It says of PHP extensions: “PHP Extensions The optional module, libsodium, is not installer, or has been disabled.”
    — It also says “HTTPS status You are not using HTTPS to access this website.”

    Everything else seems ok. Any advice on what to do? Still cannot edit any pages.

    Have you try debugging mode on in config file ?

    – If you cannot find error logs or if you don’t find any helpful info in them, try Enabling debugging

    Well, from what I understand library sodium isn’t necessary for WordPress itself.

    PHP 7.2 could possibly be the cause instead of the cure but that usually manifests itself as a missing module in PHP that keeps the database and the whole site from running.

    You could step down to PHP 5.6 if you want to check that. PHP 5.6 should run things just fine but maybe a little slower. 7.2 is faster.

    The theme you’re running, Twenty Sixteen, should be fine.

    I’m slightly worried because I can’t see your plugins manifest.

    You might kill all your plugins via Health Check and try to edit a page or post. If that should cure the problem then just turn the plugins back on one at a time to determine which one kills the editor.

    What I’d like for you to do is install and enable the Classic Editor plugin and see if that editor will let you create, edit, and save a test ‘post’… not a page I’d like a post. You can delete that once you’ve created one and then went back and edited the same then saved that edited version.

    Classic Editor will shut down your block editor. So once you’ve created, edited, saved, and even deleted that test post I’d like for you to go into

    Dashboard –> Settings –> Writing and click the ‘Allow users to switch editors’ to Yes and save that setting.

    Now try to do the above exercise again using the Block Editor and let us know if you have a problem again.

    If the Classic Editor won’t work then I suspect the update to 5.1.1 failed somehow leaving WordPress able to run but crashing in edit modes.

    If the Block Editor won’t run but Classic did then it’s either an issue with the Rest API or again the update failed partially.

    Of course, I could be wrong.


    I’m also confused about why you didn’t use the posts and blog system instead of having so many pages. I usually recommend using pages for long term information but posts for more newsworthy, short term content that might lose some meaning or relevance over time.

    Hi @immeet94 – how do I get into debugging mode on in config file ?

    Hugely grateful for advice @jnashhawkins!

    * I went to 5.6 and did a health check. Problems remain.

    * I turned off all plugins, but editor still doesn’t work.

    * Dashboard says:
    PHP 5.6.40
    MySQL 5.6.41
    Memory Usage 11,305,248 bytes
    Please Enable WP_DEBUG
    Object Cache
    Cache Hits: 744
    Cache Misses: 48
    Group: options – ( 94.73k )
    Group: default – ( 0.03k )
    Group: site-options – ( 0.03k )
    Group: users – ( 0.42k )
    Group: userlogins – ( 0.04k )
    Group: useremail – ( 0.04k )
    Group: userslugs – ( 0.03k )
    Group: user_meta – ( 3.43k )
    Group: counts – ( 0.76k )
    Group: posts – ( 31.52k )
    Group: post_meta – ( 1.73k )
    Group: themes – ( 1.18k )
    Group: terms – ( 2.25k )
    Group: post_tag_relationships – ( 0.04k )
    Group: category_relationships – ( 0.02k )
    Group: post_format_relationships – ( 0.02k )
    Group: comment – ( 0.18k )

    * I went to Dashboard -> Settings -> Writing but see this:

    Formatting Convert emoticons like πŸ™‚ and πŸ˜› to graphics on display
    WordPress should correct invalidly nested XHTML automatically

    Default Post Category Uncategorized

    Default Post Format Standard Aside Chat Gallery Link Image Quote Status Video Audio

    Post via e-mail

    To post to WordPress by e-mail you must set up a secret e-mail account with POP3 access. Any mail received at this address will be posted, so it’s a good idea to keep this address very secret. Here are three random strings you could use: Z8s1iN0K, bAQzEm5r, ymQKsmQ9.

    Mail Server
    Port

    Login Name
    Password

    Default Mail Category Uncategorized

    * Is there a way I can upload anew 5.1.1 (maybe something went wrong when did it)? Or a way to go pre-5.1.1?

    * I simply like format of post/pages as run site differently from blog. Either way, problems are all new.

    * For what it’s worth my PHP code appears like this in WordPress:

    [ HTML and PHP removed ]

    • This reply was modified 6 months, 3 weeks ago by  Jan Dembowski.

    Small update.

    I’ve uploaded plugin Classic Editor.
    I ticked on “Block Editor” – problem continues.

    Is there a way I can upload anew 5.1.1 (maybe something went wrong when did it)? Or a way to go pre-5.1.1?

    Yes, you can. This plugin will help you revert backwards… https://wordpress.org/plugins/wp-downgrade/

    You might revert back to 4.9.9 and that might show as 4.9.9.1 now. Either Or! That should get you back to the Classic Editor and Away from the Block Editor which may be the problem.

    Else, these instructions will help reinstall 5.1.1 https://www.wpbeginner.com/wp-tutorials/how-to-uninstall-and-reinstall-wordpress/

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @tbrooks55555 I don’t think it’s needed but if you do need to share that HTML and PHP please use a service such as https://pastebin.com/ and share the link to that paste instead.

    It does not work here and I’ve redacted your paste.

    I am absolutely thrilled to get such brilliant advice.

    I went to the older 4.9.9 version of WordPress. Now everything works great once again πŸ™‚

    Thank you to EVERYONE! Really solved a major problem for me!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Can’t edit website’ is closed to new replies.