Support » Plugin: RSVPMaker » Can’t edit RSVP event once created

  • Hi,

    I also get this message in the admin:
    Warning: implode(): Invalid arguments passed in /home/commcup/public_html/wp-content/plugins/rsvpmaker/rsvpmaker-plugabble.php on line 553

    I’ve tried both Chrome and Firefox to edit events but neither saves the changes.

    Thank you, jim

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author davidfcarr

    (@davidfcarr)

    I am putting out a fix for the specific error message you mentioned, which is related to the summary of fields included in an rsvp form displayed on the options screen.

    If I understand right, you’re talking about being unable to save the content of an event post, not the event options settings. In the Gutenberg editor, I’ve occasionally seen an error message saying that WordPress was unable to save a post. But if I reload in the editor or view on the front end, I see that the content has in fact been saved. I’m not clear on whether that’s a general WordPress glitch or something related to RSVPMaker. Seems to me I’ve seen it with regular blog posts as well.

    If I’m misunderstanding the issue you’re running into, let me know.

    For example, I create an event and then save it, having forgotten to update some event options like max number of attendees and ticket prices. When I update and try to save, the save process never completes.

    Plugin Author davidfcarr

    (@davidfcarr)

    I don’t know how to debug that. Not seeing it on any of my own RSVPMaker sites. You might turn on debug logging and give me the messages from the log. Or check for JavaScript errors (I doubt that’s the cause, but just in case) through the Chrome dev tools panel.

    Here’s the debug logging setup I recommend adding to wp-config.php – so you can track down errors with necessary without them being publicly displayed:

    @ini_set( ‘display_errors’, 0 );
    // Enable WP_DEBUG mode
    define( ‘WP_DEBUG’, true );
    // Disable display of errors and warnings
    define( ‘WP_DEBUG_DISPLAY’, false );
    // Enable debug logging to file, ideally outside of public_html
    define( ‘WP_DEBUG_LOG’, ‘/home/mysite/debug.log’ );
    @ini_set( ‘display_errors’, 0 );

    Should come before the line that says:

    /* That’s all, stop editing! Happy blogging. */

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.