Support » Fixing WordPress » Cant edit posts through the Text editor

  • I can’t seem to edit any posts through the Edit Posts page

    in the Admin section I am getting the following errors:

    Two of these on every page:

    Uncaught TypeError: Cannot read property ‘length’ of undefined

    And this on the Edit Post page:

    Uncaught TypeError: Object [object Object] has no method ‘uniqueId’

    I’ve tried the wp-config edits:

    define(‘CONCATENATE_SCRIPTS’, false );
    define(‘SCRIPT_DEBUG’, true)

    but to no avail!

    And finally my error log is showing no PHP errors.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator keesiemeijer



    – reading the troubleshooting 3.5 master list to see if any of your problems is listed there:

    – flushing any caching plugins you might be running, as well as server and/or browser caches.

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    – re-uploading all files & folders – except the wp-content folder from a fresh download of WordPress. by using FTP or whatever file management application your host provides (Manual Update).

    – re-running the upgrade via wp-admin/upgrade.php

    I had done all that was suggested except the plugins, as when I previously deactivated them they didn’t reactivate properly.

    I took a copy of the site and it seems to be the Jetpack plugin that causing most of my troubles.

    Moderator keesiemeijer



    You may have some JavaScript errors or conflicts.
    Uncaught TypeError: Cannot read property 'length' of undefined

    This guide will show you how to diagnose JavaScript issues in different browsers:

    Please report the javascript errors in this topic so we can identify what files are causing trouble

    I am still not able to edit any pages or add anything to them.

    Wordcount is 0 which is worrying.

    I have deactivated all plugins and reinstalled wordpress 3.5

    Moderator keesiemeijer




    Please create your own topic:

    How-To and Troubleshooting

    Uncaught TypeError: Cannot read property ‘length’ of undefined – on line 1 of /wp-includes/js/jquery/jquery.js?ver=1.8.3

    Uncaught TypeError: Object [object Object] has no method ‘uniqueId’ on line 5 of /wp-includes/js/jquery/ui/

    are the two errors I’m still getting! disabling plugins didnt seem to help!

    Errors are showing in Chrome

    In firfox the errors are as follows:

    e is undefined on line 1 of /wp-includes/js/jquery/jquery.js?ver=1.8.3

    and this.element.uniqueId is not a function on line 5 of /wp-includes/js/jquery/ui/

    SCRIPT_DEBUG did not resolve the issue

    Moderator keesiemeijer



    Can you also show us the contents of your .htaccess file.

    It was a lot more complex but I cut it back to the following to see if the issue was there:

    BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    I have the same situation.

    The reason of that issue in my case was “kk Star Ratings” plugin.

    “kk Star Ratings” plugin fixed this in Version 2.2

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Cant edit posts through the Text editor’ is closed to new replies.