Support » Plugin: Gutenberg » Can’t edit posts since updating to version 8.9

  • Resolved Insaitama

    (@insaitama)


    Hi! I updated to the latest version about an hour ago, went to edit a post straight after and got a blank white screen. So tested it out with dozens of posts – all the same. I can do a “quick edit” from the wp-admin/edit.php page. I can also edit events (the events calendar). I found a quick fix – I added the “classic editor” plugin again and have been able to edit posts that way. But I’d rather not use the classic editor long term. Is a common problem with the latest version? Or what’s happening and what do I need to do? I am not a very technical person, please don’t give me code!! Thank you very much in advance.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Riad Benguella

    (@youknowriad)

    Hi there! would you mind checking the browser’s console to see if you have any javascript errors when you get the blank page?

    Also, you might want to try disabling the plugins you have one by one to see if there are any potential conflicts.

    Sorry for the inconvenience. And your help figuring out the issue is appreciated.

    I have no idea what this means!, but this is what I get:

    START

    index.js?ver=e61d0052c527a4cf427678318796462b:1 Moment Timezone has no data for Asia/Tokyo. See http://momentjs.com/timezone/docs/#/data-loading/.
    j @ index.js?ver=e61d0052c527a4cf427678318796462b:1
    5A cookie associated with a cross-site resource at <URL> was set without the SameSite attribute. It has been blocked, as Chrome now only delivers cookies with cross-site requests if they are set with SameSite=None and Secure. You can review cookies in developer tools under Application>Storage>Cookies and see more details at <URL> and <URL>.
    admin.js?ver=1.3.2:1348 undefined undefined
    post-edit-1490.js:1 Uncaught (in promise) TypeError: Cannot read property ‘source_url’ of null
    at post-edit-1490.js:1
    at index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    at Array.forEach (<anonymous>)
    at o (index.js?ver=86e17756483edb79c5c2acf422ecb400:1)
    at index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    at p (index.js?ver=86e17756483edb79c5c2acf422ecb400:1)
    at index.js?ver=ad785dcae37e85d5d48a4af4f6b5e6d8:1
    at index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    at index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    at dispatch (index.js?ver=86e17756483edb79c5c2acf422ecb400:1)

    END

    I just deactivated the Gutenberg plug-in and it fixed the problem: no more white screen and I can edit fine 🙁 Which implies its the latest update eh?

    I don’t want to leave it deactivated, but will have to temporarily so I can work on my posts.

    Plugin Author Riad Benguella

    (@youknowriad)

    There’s two issues here, the first one is just a warning and is tracked here https://github.com/WordPress/gutenberg/issues/22193

    The second one is the blocking issue:

    
    post-edit-1490.js:1 Uncaught (in promise) TypeError: Cannot read property ‘source_url’ of null
    at post-edit-1490.js:1
    at index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    at Array.forEach (<anonymous>)
    at o (index.js?ver=86e17756483edb79c5c2acf422ecb400:1)
    at index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    at p (index.js?ver=86e17756483edb79c5c2acf422ecb400:1)
    at index.js?ver=ad785dcae37e85d5d48a4af4f6b5e6d8:1
    at index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    at index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    at dispatch (index.js?ver=86e17756483edb79c5c2acf422ecb400:1)
    

    That said, it’s very hard for me to know where the issue comes from that, I need to know more about how to reproduce, did you try disabling your other plugins to see if there’s anyone causing conflicts.

    So I re-enabled the Gutenberg and disabled all other plug ins and the editor would work again. I am currently going through them one by one to find the culprit, so it might take sometime. But you were right, there is a conflict. I’ll post later which one, when I find it.

    Its Yoast SEO!! I tried it first with several other plug-ins activated and then afterward with just YOAST SEO and the Gutenberg plug-in activated and I get the white screen when I try to edit.

    Plugin Author Riad Benguella

    (@youknowriad)

    Ohh! it seems related to this issue https://github.com/WordPress/gutenberg/issues/25045

    We’re actively working on it and hopefully, we’ll be releasing a patch version soon.

    I am having the same problems and thought it might be some Gutenberg block add-ins that were causing the problem, since not only couldn’t I edit anything in block editor mode but the pages were not rendering these custom blocks anymore. I tried deactivating Gutenberg Post Blocks and Advanced Gutenberg but to no avail. But I also have Yoast SEO, so this is the likely culprit. I have downgraded to 8.8.0 in the meantime and am looking forward to the patch.

    • This reply was modified 3 weeks, 1 day ago by revschaef.

    Ok, thank you very much. I will follow that now. Thank you very much for your patience and help.

    Plugin Author Riad Benguella

    (@youknowriad)

    We just released a patch version 8.9.1. Let me know if fixes your issues.

    Hi Riad, updated to 8.9.1 and all looks good! I am able to edit, NO white screen and can’t see any problems, everything seems in order so far (y) Thank you.

    Plugin Author Riad Benguella

    (@youknowriad)

    Awesome

    Same here. I’m still having trouble with another plug-in, but I think that’s on them. I’m able to edit and the white screen is gone. Thanks for the update.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.