WordPress.org

Support

Support » How-To and Troubleshooting » Can't edit posts – Autosave is messing up

Can't edit posts – Autosave is messing up

  • This just started recently and I can’t attribute it to any plugin changes as far as I can remember.

    It seems like I can edit newer posts, but not old posts (before I upgraded from legacy WP.) Again, this just started – I was able to edit old posts a couple weeks ago (I upgraded months ago.)

    When I update the post and hit the “Update” button, it reverts to the previous unmodified version and gives me the error: “There is an autosave of this post that is more recent than the version below. View the autosave.” When I click on “View the autosave” it shows me the correct, modified version of the post, but when I click on “Restore,” it just gives me that error again and goes back to the old version.

    It’s like it’s saving the correct version as autosave but won’t let me revert to it. This is driving me nuts!

Viewing 15 replies - 1 through 15 (of 22 total)
  • I haven’t been able to figure out exactly which posts will update and which will, but it just seems like it’s the older ones that won’t.

    bump…can anybody give me hand?

    Sorry to keep bumping this, but does nobody have a clue what’s going on?

    Have you tried turning off AutoSave for a bit?

    Tried that (commenting out the autosave line on post-new.php and post.php)

    No luck, still says there’s a newer autosave version and won’t revert to it.

    Sounds like you need to manually edit the entries in the “wp_posts” table in the DB.

    First back up the table, then delete the entries that you can’t update after making sure that the auto-save versions are present. Then, for each auto-save, make sure of the following:

    Column “id” = the correct numeric id for the entry
    Column “post_status” = “publish”
    Column “post_name” = “the-correct-slug-for-your-page”
    Column “guid” = “http://yoururl.com/?p=the same numeric id as above”
    Column “post_type” = “post” or “page”

    Thanks for the reply, but is there any way to do this without my brain exploding? 🙂 Are you saying I need to do this to EACH of the hundreds of posts affected?

    This seems to be a “worked one minute, suddenly it won’t work anymore” thing, so I’d think there would be a solution that would just reverse it.

    Ok it looks like if I edit an old post but edit and save it before autosave kicks in it’s fine and updates ok. It’s only when it autosaves does it give me an issue.

    I edited post.php to disable autosave but I still have posts that did autosave that I desperately need to edit.

    There was a plugin out there that did that… Can’t remember what it was. Might be post revision management or something similar.

    A plugin that caused the problem or fixed it? I wonder if it was a plugin update that did it because I haven’t added any plugins lately.

    esmi

    @esmi

    Forum Moderator

    If it’s a revision control management plugin you’re after – Revision Control

    That was the one I was thinking. You can use Revision Control to clean up old post revisions, which should help you with old posts.

    Also use this link: http://wordpress.org/extend/plugins/revision-control/

    (esmi, yours is locked for registered users only?)

    esmi

    @esmi

    Forum Moderator

    Oops – hadn’t realised that. I’ll correct it for any future posts. Thanks for the heads-up.

    I am glad someone else is having this issue because it just started for me too. Maybe it is a glitch in WordPress?

    I open any old post, even one I wrote yesterday, make a change and hit Update. It wipes out my updates. I downloaded and installed that plug-in suggested above and it does nothing.

    Help!! I have thousands of posts on my site.

    Agrr, I see I am not the only one… this thing is driving me nuts! I can’t update my pages, I can’t delete them I can’t change their status from draft to published…

    I need to blow some steam now, this is horrible 🙁

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Can't edit posts – Autosave is messing up’ is closed to new replies.