[resolved] Can't edit post text formatting (Visual link doesn't work) (4 posts)

  1. martin787
    Posted 3 years ago #

    After upgrading to 3.5 I can't format the text of my posts. The "Visual" tab link is not working.

    Ran Chrome's JS Console and I get the following error when I click on "Visual":

    Uncaught TypeError: Cannot read property 'canvas' of undefined load-scripts.php:45
    c.closeAllTags load-scripts.php:45
    switchEditors.go load-scripts.php:455
    switchEditors.switchto load-scripts.php:455
  2. Have you tried:
    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the 2010 theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  3. martin787
    Posted 3 years ago #

    I found this "hack" on another thread that worked:

    Add the line below to wp-config.php.
    define('CONCATENATE_SCRIPTS', false );

    I understand the "impact" and for now it's not a big deal for us.

    Thanks a lot!

  4. Great, glad to know that this works. I'll mark this thread as resolved so that others who might have the same issue can find the solution.

Topic Closed

This topic has been closed to new replies.

About this Topic