Support » Fixing WordPress » Can’t edit pages after WordPress update to 4.9

  • Since I updated this morning WordPress into the 4.9 version, I can’t edit my pages.

    I tried to edit several pages and it doesn’t work.

    In fact, what I did:
    – I edit a section of the page in Visual Composer
    – I want to save the modifications of the concerned section but Visual Composer stays open and doesn’t close the modifications window.

    I don’t know what to do. Thank you for your help!

    Cynthia

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 32 total)
  • I just tried checking if I was able to edit page on my self-hosted WordPress blog on WordPress 4.9, and everything’s pretty fine. I am even able to make modifications and save them.

    There could be various reasons why a certain something is wrong/not working on your self-hosted WordPress site. The primary causes being plugins or modifications done to your self-hosted WordPress site’s templates.

    Are you sure you haven’t made any change in particular after updating your self-hosted WordPress site to WordPress 4.9?

    I don’t think so. I’ve just updated WordPress and then, tried to update a page.

    (Just for your information, I have the same issue in a testing domain with the same plugins and pages).

    Moderator Marius L. J.

    (@clorith)

    You’ll likely need to wait for Visual Composer to update, as you mentioned using it, could you try disabling it and seeing if that’s the cause?

    The Fusion builder by Avada does exactly the same – it seems that some javascript error is causing the problem: Uncaught TypeError: Cannot read property ‘addClass’ of undefined – source seems to be color-picker.min and other javascripts and jQuery too. I guess both developers will publish updates soon since a lot of people are using them.

    Cheers

    Thanks for the answers!

    I’ll wait an update… I hope it will come soon 🙂

    Hi Cynthia

    I’ve had the same problem with Visual Composer since the WordPress update. I don’t know what browser you’re using but I was using Firefox, where I couldn’t save edits at all.

    I tried switching to Chrome, where it did save edits, although in a glitchy way, with the view jumping down to the bottom of the page after saving.

    Like you, I’m hoping for an update soon …

    Russ

    Exactly Russ, I use Firefox.

    I’ll try in the browser Chrome. Thank you!

    Hope it works for you Cynthia, albeit in an imperfect way …

    It works! With the same glitch but at least I can save my modifications.

    Thank you Russ

    Great! Glad to have helped 🙂

    Hi again Cynthia

    Maybe you’ve already seen, but Visual Composer has now been updated and everything seems to be working fine in Firefox again 🙂

    Best wishes
    Russ

    Hello Russ,

    Thanks for the tip!

    I don’t see the update for now…

    I’ll wait today and see.

    Thanks again

    Regards,
    Cynthia

    Hi Cynthia

    Hmm, that’s strange that you don’t see the update.

    I have Visual Composer installed as a plugin that came bundled with a theme, and (now that I look) I see that version 5.4.3 was made available two days ago, with these changes: “Fix: Improve WordPress 4.9 tinyMCE support, Compatibility: with WordPress 4.9, Compatibility: with WP Tool Set plugin.” As soon as I applied the update to that version, all my problems were solved.

    Hope your problems are all solved soon too …

    Regards
    Russ

    • This reply was modified 2 years, 3 months ago by RussWilley.

    I’m having this same issue with Fusion Builder 1.0.4
    A click on Fusion Builder buttons (Save, Cancel) triggers the following error:
    Uncaught TypeError: Cannot read property ‘addClass’ of undefined

    This appears to be related to Javascript and JQuery libraries.

    This error occurs whether I use Chrome or IE.

    Same issue for me. Fusion builder 1.2.2 and upon hitting the save button the following error occurs:

    Uncaught TypeError: Cannot read property ‘addClass’ of undefined
    color-picker.min.js?ver=4.9:1

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Can’t edit pages after WordPress update to 4.9’ is closed to new replies.