Support » Plugin: Elementor Page Builder » Cant edit pages after updating to 2.6.7

  • Resolved achkarsten

    (@achkarsten)


    Hello together! 🙂

    I´m encountering a problem while trying to edit pages after the update to Elementor 2.6.7 today. When I open a page in Elementor, it crashes while loading and shows an error 500.

    It happens on all pages in my WordPress-instance.

    The complete error-message is:

    Uncaught TypeError: Argument 1 passed to Elementor\Controls_Stack::sanitize_settings() must be of the type array, null given, called in /path/to/my/wordpress/installation/wp-content/plugins/elementor/includes/base/controls-stack.php on line 1022 and defined in /path/to/my/wordpress/installation/wp-content/plugins/elementor/includes/base/controls-stack.php:1933
    Stack trace:
    #0 /path/to/my/wordpress/installation/wp-content/plugins/elementor/includes/base/controls-stack.php(1022): Elementor\Controls_Stack->sanitize_settings(NULL)
    #1 /path/to/my/wordpress/installation/wp-content/plugins/elementor/includes/base/controls-stack.php(1775): Elementor\Controls_Stack->get_data('settings')
    #2 /path/to/my/wordpress/installation/wp-content/plugins/elementor/core/base/base-object.php(132): Elementor\Controls_Stack->get_init_settings()

    I tried the typical steps (disabling Elementor and enabling it again, clearing all caches) but nothing worked for now.

    Do you have any idea what I can try to edit pages again?

    Kind regards and have a nice day!

Viewing 1 replies (of 1 total)
  • Plugin Support Lisa R

    (@lisaelementor)

    Hi all,

    We found the issue, it is caused by the way Ocean Elementor widgets plugin is enqueuing styles.

    Since v2.6.7 we are enqueuing all of the styles of all of the widgets in the editor.

    We have contacted the Ocean author to resolve this issue.
    For now you can rollback to version 2.6.6 until a patch will be released by Ocean Elementor Widgets plugin.

    • This reply was modified 6 months ago by Lisa R.
Viewing 1 replies (of 1 total)
  • The topic ‘Cant edit pages after updating to 2.6.7’ is closed to new replies.