• Resolved spembleton

    (@spembleton)


    I am having difficulty editing all of my pages. Up until a couple of weeks age, everything worked fine. I do not edit my pages frequently so I am not sure when this problem first occurred.

    Now, when I select edit page either using the menu bar in the admin account, or select Pages/All Pages and then select edit under any page, I get the following error:

    This site can’t be reached
    The webpage at https://www.xxxxx\.com/wp-admin/post.php?post=916&action=edit might be temporarily down or it may have moved permanently to a new web address.
    ERR_HTTP2_PROTOCOL_ERROR

    If I deactivate all of my plugins except WooCommerce and Jet pack, I get the same result.

    If I reactivate all of the plugins and deactivate just Jet Pack, I am able to edit the page, but there is no template while editing. After editing, I can reactivate Jetpack and all if fine. The edits took.

    Recently I installed AMP, but have since deactivated and then removed that plugin.

    Any ideas?`

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Jay (a11n)

    (@bluejay77)

    Could you please post your site URL here so that we can have a look?

    If you want it to remain private, you can also contact us via this contact form. If you choose to reach out directly, please include a link to this thread.

    Thanks!

    Thread Starter spembleton

    (@spembleton)

    No problem. Site is http://www.cheapjumprings.com

    Plugin Support Bruce (a11n)

    (@bruceallen)

    Happiness Engineer

    Hi @spembleton

    I took a look and our requests to XMLRPC are timing out. Can you ask your host if there are any server settings or security measures that would cause requests to XMLRPC to time out?

    Jetpack and mobile apps require unlimited access to XMLRPC, and the host may be able to whitelist by IP or user agent. For example, the IPS provided here

    https://jetpack.com/support/hosting-faq/.

    Thread Starter spembleton

    (@spembleton)

    I have contacted my host (GoDaddy) and they do not see any problem. Furthermore, since this problem only occurs on 1 of my 2 websites, they do not feel that it is a hosting issue.

    Plugin Support Mehdi (a11n)

    (@muffinpeace)

    Hi @spembleton

    This seems odd as I initially thought you were editing your pages through the mobile app, but upon checking again, I can see that you must be editing the pages through your WordPress Admin dashboard.

    From the error, it seems that there’s an issue happening with the HTTP 2 protocol. Can you share more specific information about which browser you’re currently using and the version?

    We would also appreciate it if you came back with the server logs, specifically those that were taken when the error happened.

    As told previously, if you want it to remain private, you can also contact us via this contact form. If you choose to reach out directly, please include a link to this thread.

    Best,

    Thread Starter spembleton

    (@spembleton)

    I don’t think I have a problem continuing to converse on this forum. Nothing really private on my site. Do you prefer, or do think it is more prudent to go private?

    Regarding the logs, I have 2 files in my log folder: cheapjumprings-ssl_log-Oct-2021.gz and cheapjumprings.com-Oct-2021.gz Do you want to see both, and what is the best way to get them to you?

    Regarding the browsers, I primarily I use Google Chrome Version 94.0.4606.71 (Official Build) (64-bit),but I have also checked it with Microsoft Edge Version 94.0.992.38 (Official build) (64-bit) – I get the same error and Firefox 92.0.1 (64-bit) – here I get a different error “Secure Connection failed”

    Two additional bits of information:
    When I go to a store page, and select Edit Categories from the menu bar on the admin page, all works fine

    Additionally, I have 2 websites . The other is http://www.pembletonHRConsulting.com which is also WordPress hosted on GoDaddy, which works fine. This one is NOT a WooCommerce site, but it does have Jetpack installed.

    @spembleton

    We do prefer that you send the logs information via our Support. This way, you can attach the log files and screenshots with the issue directly.

    Mal-intentioned people could use the files to investigate your sites, and it is not secure.

    Thank you.

    Let me know if you have any questions.

    My best regards,

    Michelle P.

    Thread Starter spembleton

    (@spembleton)

    I hope I am not becoming high maintenance, but I am not real familiar with this process. How do I “send the logs via our support”

    Plugin Support Bruce (a11n)

    (@bruceallen)

    Happiness Engineer

    Hi @spembleton

    First, could you contact us via this contact form and mention this thread?

    Then when we respond via email, you will be able to attach the logs so we can see them.

    > ERR_HTTP2_PROTOCOL_ERROR

    I see that this site http://www.cheapjumprings.com is hosted with GoDaddy, and we’ve seen quite a few reports of this error happening on sites hosted with GoDaddy.

    I see suggestions for fixing this in this support forum thread:

    https://wordpress.org/support/topic/woocommerce-causing-err_http2_protocol_error-2/#post-14909491

    You may want to reach out to the support team of your hosting service provider for assistance with the implementation of the fix suggested in the comments (the edit of the .htaccess file):

    > # BEGIN Line too long fix
    <IfModule mod_substitute.c>
    SubstituteMaxLineLength 10M
    </IfModule>
    # END Line too long fix

    https://godaddy.com/help/contact-us

    I hope this helps!

    Plugin Support Animesh Gaurav (a11n)

    (@bizanimesh)

    Thanks for sharing @grigaswp 🙂

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Can’t edit pages’ is closed to new replies.