Support » Plugin: MailPoet Newsletters (Previous) » Can't Edit Name of the Forms and Can't add Fields

  • Tried on several domains but unable to rename the name of the Forms. Moreover only email is available to subscribe. There are options to add fields like “First Name” or “Last Name” but you can’t add.

    Plugin is very good but these limitations are annoying.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Your limitation, not theirs:

    Go to Settings
    select ‘Forms’ tab
    ‘edit’ the form in question
    beside the form title on top is an ‘Edit Name’ button, click that and edit the form name.

    Also, click on the field in that screen and an ‘Edit Display’ button appears, click on that and change the field name.

    You find options for everything when you click on things.

    Very funny answer, by expert one and thinks that others are idiots.
    These all things are not enabled. There is something wrong with plugin, not me….
    be wise to comment, don’t behave like a kid.

    Alta

    (@shellardee)

    It could be your theme interfering with this – or even another plugin. Perhaps the server configuration or you modified the code somewhere? Unfortunately, some installations interfere with other installations. I found this happening with many plugins, especially if they are outdated.

    Do you not see the “Forms” tab? Mailpoet > Settings and at the top should be a “Forms” tab.

    If so, click “Forms” then click the demo one there to edit it (just like editing posts and pages) – or you can add a new one.

    At the top, you can “Edit Name“. Search the page for “edit name” to find it. This means to edit the name of the form.

    To the right or below the main content will be widgets that you can drag and drop onto the form to add the “first name”, “last name”. You can even “add a new field”. To add a new fields, you need to know something about html forms.

    HTH! If not, try uninstalling and reinstalling the form or go through troubleshooting to find out if another plugin or your theme is interferring. (E.g., diable plugins and test. Enable another generic theme and test.)

    I have a similar problem on a brand new installation of wordpress and mailpoet.

    Everything works fine on my existing sites, but I can’t get it to work on this new installation.

    I’ve reinstalled mailpoet, and even reinstalled wordpress entirely. Tried different themes.

    When I try to change the name of the form, the text changes to “Saving…” and then never changes to anything else. If I then click the save button, that change isn’t saved anyway, it’s still called “New Form”.

    I also can’t change the text of the subscribe button.

    I haven’t tried doing anything else on this form, but it’s a strange one!

    After talking with support, have a look at this link, maybe it will solve your problem as it did mine:

    https://support.mailpoet.com/error-403-on-admin-ajax-php/

    Same problem… can’t edit/update forms. Can add New Form but can’t add items or change the default options of Email label and Subscribe! button.
    New installation.
    Tried advice from above link but to no avail.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Can't Edit Name of the Forms and Can't add Fields’ is closed to new replies.