Support » Fixing WordPress » Can’t edit my website after upgrading to 4.8.3

  • I upgraded my site to 4.8.3 and it returned with some errors but my site http://www.mariakoropecky.com is still live on the internet. I have tried to make edits like changing words on an existing page but when I update the page, it says “Oops! That page can’t be found.”

    I also tried to create a test page and it won’t let me add media.

    What do I need to do to make edits and add pages to my site? Thanks in advance for your help. Maria

    The page I need help with: [log in to see the link]

Viewing 5 replies - 16 through 20 (of 20 total)
  • Maria,

    If you are really nervous about doing this, you may want to watch someone do it several times. There are people who have done videos about it. However, when you do it, use the instructions t-p gave you.

    I did this when I first started and it helped me to understand what the WP instructions were telling me to do. Nothing like having a “visual.”

    Best of luck.

    Hi y’all!
    I’m a friend of wellness3 and helped them update WordPress to 4.9.4. It wasn’t updating automatically because they had the cpanel plugin active (see https://wptavern.com/cpanels-site-software-addon-disables-wordpress-auto-updates). Also cpanel wasn’t updating WordPress because it’s WordPress add-on has been deprecated (see https://confluence1.cpanel.net/plugins/servlet/mobile?contentId=2434090#HowtoInstallWordPressWithcPanel-InstalltheWordPresscPAddon under “install the WordPres cPAddon”).

    So now the site is on WP 4.9.4, but we’re still getting an error when saving posts. I created another support forum question (because I didn’t know this one existed already) at https://wordpress.stackexchange.com/questions/72766/getting-404s-on-new-pages and it has quite a few more details about the issue.
    I suppose a moderator should close this thread or that new one I created.

    Moderator t-p

    (@t-p)

    Side note to @mnelson4,

    please do not jump into other topics. If the troubleshooting already posted made no difference for you, then, as per the Forum Welcome, please post your own topic. A lot more people will see your post this way.

    thanks @t-p, but I tried to explain that what I was posting wasn’t a separate topic. It’s actually a duplicate report of the same issue (wellness3 first reported the issue; and then I heard about her problem separately on facebook and helped out a bit, but then created another support forum post because I didn’t know she had already created one).

    Anyways, as noted on that other issue, it seems the host has some modsecurity rules that are interfering with requests to update posts. The host, however, is unwilling to verify the issue (they just assume “it’s a WordPress issue”, even though it’s reproducible on a fresh WP with the default theme and no plugins active, and does NOT occur with the same setup on a different server). The solution seems to be to switch hosts :(.

    Anyways, I think this issue is resolved.

    Thank you, Michael for helping me out and to everyone else who commented on this issue. I’m in the process of switching hosting companies. Maria

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘Can’t edit my website after upgrading to 4.8.3’ is closed to new replies.