Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Can’t edit my site from WordPress.com anymore, redirects to WP-Admin

  • Resolved brulosopher

    (@brulosopher)


    Despite having a website on my own server (Brulosophy.com), I hugely prefer editing from WordPress.com, which requires Jetpack, rather than WP-Admin. A few weeks ago, as I was going to edit an article, I clicked “Add new post” and was redirected to WP-Admin editor. I figured it was a temporary issue, but nothing has changed.

    I do not have an active WordPress dot COM website, I only have my self-hosted site, brulosophy.com, and I have no problems editing from WP-Admin. However, with Jetpack installed, I’m able to use WordPress dot com to check my stats as well as edit posts and pages, it’s what I’ve been doing for years and far prefer over WP-Admin.

    After changing absolutely nothing on my end, whenever I use WordPress dot COM to edit posts (https://wordpress.com/posts/brulosophy.com), rather than opening up a new post with the white and light blue background on WordPress dot com, it now redirects me to WP-Admin.

    I apologize for the redundancy, just trying to be as clear as possible. I will freaking pay someone to help me with this at this point!

    Thanks!

Viewing 15 replies - 31 through 45 (of 62 total)
  • Plugin Contributor Jen H.

    (@jenhooks)

    Hey @brulosopher. Thanks for your patience and persistence with this.

    It looks like your site is loading at both http and https URLs. This is problematic for your site’s communication with WordPress.com, as our system does not know which address it should communicate with. I’m not positive if this is the source of the problem you’re having, but it’s worth sorting.

    Please go to Settings > General in your WP Admin, and use https in your URLs, rather than http. Then, ask your host to ensure that your traffic to http is all redirected to https. This is something they should easily be able to do for you. If your host is unable to help, you can find guidance on doing this yourself, here.

    Once done, please reconnect your site to Jetpack.

    After you do the above, let us know if you’re able to edit your site on WordPress.com as you’d expect to.

    Thread Starter brulosopher

    (@brulosopher)

    Well, after clearing cookies, I changed my URLs to https as instructed, but when I pressed save, it opened a “This page isn’t working” page. Every time I try to login to wp-admin, this is what I get. I am able to login to Calypso, but when I try to edit an article or draft, it still redirects me to wp-admin… which is that aforementioned error page.

    I’m a bit anxious now, as I was in the middle of editing an article that needs to be ready soon.

    Plugin Contributor Jen H.

    (@jenhooks)

    Thanks for the update. Did you work with your host to ensure that all of your traffic is redirecting to the https version of your URL (https://brulosophy.com/)?

    Thread Starter brulosopher

    (@brulosopher)

    Yep, still on the line with them in fact. They had me install the Really Simple SSL plugin (from Calypso), but that’s still not allowing me to access wp-admin 😐

    Thread Starter brulosopher

    (@brulosopher)

    Okay, it was something with Sucuri, I think we’re back in action. I’ve gotta run for now, I’ll check Calypso again this evening. Thanks!

    Thread Starter brulosopher

    (@brulosopher)

    Everything else is looking good, but I’m still getting redirected to wp-admin when trying to edit from Calypso.

    Plugin Contributor Ryan C.

    (@ryancowles)

    Thanks again for the update. Now that you have sorted the http vs. https issue, can you please try reconnecting Jetpack?

    You can follow these instructions to do that:

    https://jetpack.com/support/reconnecting-reinstalling-jetpack/#disconnecting-jetpack

    After reconnecting Jetpack, see if the issue is resolved. Please let us know how that works for you, and we can go from there!

    Thread Starter brulosopher

    (@brulosopher)

    @ryancowles – Disconnected and reconnected Jetpack, no change; I’m still redirected to wp-admin when attempting to edit from Calypso.

    Thread Starter brulosopher

    (@brulosopher)

    Just deactivated, deleted, reinstalled, and reconnected Jetpack. Still nada.

    Thread Starter brulosopher

    (@brulosopher)

    Okay, so here’s another issue I’m running into, which I believe to be related to the recent change form http to https.

    I used a plugin called BeerXML Shortcode to display beer recipes, which are in .xml format. Since yesterday, when I try to put a recipe in an article, it shows the following error message rather than the recipe:

    XML not retrieved: cURL error 60: Peer’s Certificate has expired.

    I’ve currently got open tickets with both my host and Sucuri. Any idea what might be causing this issue?

    Plugin Contributor Dan (a11n)

    (@drawmyface)

    I’m not sure about that cURL error. I don’t see any issues with your SSL certificate, but your host may be able to advise further on that.

    As for the redirect issue, this may be a bug. I’ve added a comment for our developers here: https://github.com/Automattic/wp-calypso/issues/47118

    Can you try enabling WordPress.com login (Manage > Settings > Security > WordPress.com Login)? You can then log in to your site using your WordPress.com login, and that should allow you to edit your posts in WordPress.com as a temporary measure.

    Let us know how that goes.

    Thread Starter brulosopher

    (@brulosopher)

    Figured out the cURL issue – the plugin wasn’t recognizing the httpS URL of the recipe file; deleting the “s” resolved the issue.

    Made the change you suggested and no change, I’m still being redirected to wp-admin.

    Plugin Contributor Ryan C.

    (@ryancowles)

    Thanks again for the update. It seems we’ve ruled a number of things out, but we’re still back to step one.

    I’ve commented on the GitHub Issue that Dan linked to above, to ask our developers to look into this further. We’ll followup with them and let you know as soon as we have more information.

    Again, thanks for your help and patience so far!

    Thread Starter brulosopher

    (@brulosopher)

    Happy to do what I can to help, and I can’t tell you how much appreciate the time you’re all spending on this issue with me. Thank you!!

    So, I did some experimenting a little bit tonight, which involved me doing the following in order:

    1. Deactivate and delete Classic Editor plugin
    2. Deactivate and delete Jetpack plugin
    3. Install and activate Jetpack plugin

    Now, when I hover over a draft link, published post, or “Add new post” in Calypso, the associated link looks like it used to before the problem started, rather than showing the wp-admin link. Here’s a pic.

    When I click a link to edit, it initially shows a blank page for about 2 seconds, then this shows up, sometimes with a message that says something like, “Brulosophy.com is not connecting.”

    After another 2-3 seconds, I get automatically redirected to wp-admin, you can see the URL here.

    This is obviously a step in the right direction, but it’s still not working properly. Close but no cigar!

    Thread Starter brulosopher

    (@brulosopher)

    After doing multiple hard refreshes in both wp-admin and Calypso, nothing was changing, so out of curiosity, I reinstalled Classic Editor. Sure enough, hovering over a link in Calypso now shows the wp-admin URL. Seems like this plugin is at least part of the issue.

Viewing 15 replies - 31 through 45 (of 62 total)
  • The topic ‘Can’t edit my site from WordPress.com anymore, redirects to WP-Admin’ is closed to new replies.