Support » Fixing WordPress » can’t edit my posts

  • I have just installed WordPress and am working through it to try to get a feel for how it works.

    I have done a few test posts, but can’t seem to edit my posts. I can delete them, but when I hit the ‘edit’ button, a blank page comes up with the ‘Write’ tab and the ‘Write Post’ tab highlighted.

    I have tried searching the documentation wiki and the support forums, but haven’t seen anything about a problem like this. So far, I am the only user, and I am working with Firefox on a Mac running OS X 10.3.

    Is there something I’m missing. Any help would be appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • “Is there something I’m missing.”

    That’s always possible for nondescript problems like this. I’d first try deleting all files from the wp-admin/ and wp-includes/ directories and reinstall those from your WordPress download.

    I just tried uploading everything again (without changing the database), and it seems that nothing has changed. I notice also that the ‘Write Page’ tab under the ‘Write’ tab brings up a blank page as well – the ‘Write Post’ tab seems to work fine.

    I uploaded these files using the FTP function in Adobe GoLive – could that be the problem?

    I just tried uploading everything again using Transmit, just in case GoLive 6 was the problem. Nothing seems to have changed.

    I’m getting kind of frustrated; the five-minute install took about that long, but actually getting it to work right is taking a lot longer…

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    ::sigh:: In my entire history here, GoLive has always been the problem. I’ll add it as an FAQ if I get some spare time today.

    Mark (podz)

    (@podz)

    Support Maven

    Did you delete the old files before uploading the new ?
    Have you checked for any zero filesize files ?

    Adobe products – not as good as they say.

    Thanks for your replies. Yes, though I mostly love GoLive (and other Adobe software) it is (they are) not perfect and has given me a few problems in the past with uploading. But I just used Transmit, and the problem persists.

    Yes, I did delete the old files before uploading the new.

    Just checked the server for zero filesize files, and there are none.

    Also just checked with my hosting service, and they are running mySQL version 4.0.23 and php version 4.3.10

    Mark (podz)

    (@podz)

    Support Maven

    Are you able to check in another broswer ?
    That may help to show if indeed it is a browser problem or an ftp problem.

    I have checked in:
    Safari 1.3
    Firefox 1.0.4
    Internet Explorer 5.2
    With the same results in all three browsers.

    Mark (podz)

    (@podz)

    Support Maven

    Hmm…..

    You could allow someone else on a PC access to let them look
    You could delete the files and use ones from a fresh download
    You could use another ftp client

    I’d say it’s an ftp error ….

    I’ll borrow a friend’s PC and see if that makes a difference.

    I’ll try a fresh download.

    I’ve tried two ftp clients (GoLive and Transmit), but I’ll see if I can find another.

    Thanks much.

    Did a fresh download, and uploaded with GoLive – it works! Haven’t checked everything, but I can edit posts and the ‘write page’ tab now works.

    I guess something was corrupted in the download.

    In any case, it seems to be working.

    Thanks for your help.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘can’t edit my posts’ is closed to new replies.