WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Can't edit menu, new pages automatically added erroneously (6 posts)

  1. signcarver
    Member
    Posted 1 year ago #

    I am unable to edit the main menu (Dashboard > Appearances > Menu)

    When i add a new test page it is automatically added to the menu even though the "Automatically add new top-level pages" check box is unchecked in the Appearance > Menus page.

    I have deactivated all plugins - still a problem.

    I have also deleted the menu several times but the old menu is still remembered when i view the pages. So nothing shows up in the menu (Appearances > Menu) but when i preview the pages the menu is visible.

    Also, the menu items are forced into alphabetical order.

    Also, i can't seem to add a Custom menu item.

  2. Can you provide a link to your site?
    Also if you are using a caching plugin, you may want to clear your cache.

  3. signcarver
    Member
    Posted 1 year ago #

    Hi Christine,

    Link to my site

    I am not using a caching plugin. I have cleared the server cache and browser cache.

    Also, i did check and optimize the mysql db (no errors)

  4. Looking at your site I see that it's using Catalyst. Did you make this site using this framework? Are you sure that it supports menus? Maybe try asking on their support forums to see if the menu can be altered?

    It's hard for me or anyone else to be able to help, since one needs to pay for it to see how the header is coded.

  5. signcarver
    Member
    Posted 1 year ago #

    Hi Christine,

    Yes i am using Catalyst but i have used it on about 10 other web sites and never had a problem.

    I am using the WordPress menu with no (apparent) Catalyst intervention.

    Could i provide you with the login to the site so you could look at it?

    Thanks,
    Steve

  6. signcarver
    Member
    Posted 1 year ago #

    @Christine - per your suggestion i posted my issue on the Catalyst forum and a kind soul there found my issue.

    I had to set some options in Catalyst that i had forgot about.

    Thank you again for the suggestion!

Topic Closed

This topic has been closed to new replies.

About this Topic