Support » Fixing WordPress » Can’t edit main theme php files after upgrading to 4.9

  • Derick Payne

    (@petrichorpost)


    I am unable to edit main theme (php) files using the build in WordPress editor after upgrading to version 4.9. I get the following error:

    Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.

    I have cleared my browser cache, cleared my website cache, de-activated all plugins and reinstalled main theme.

    Furthermore; I am able to edit php files in other themes without issues. I have also checked my permissions and ownership of all files. Everything seems perfect.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 126 total)
  • Moderator Marius L. J.

    (@clorith)

    Might i ask what host you are using for your live site?

    HI

    I wish to report we are also seeing this this error across multiples sites on multiple hosting platforms. If anyone tries to edit an php file of a theme we get the exact same result as others reported:

    Unable to communicate back with site to check for fatal errors, so the PHP change was reverted. You will need to upload your PHP file change by some other means, such as by using SFTP.

    If we perform the edit of the file.php deleting lines 491-598 in file.php as indicated by Backups above, the issue is resolved.

    Your sandbox function is in error. Please fix.

    @clorith

    any host. I tested 3 different ones now in the netherlands. One in the UK TMZ, two in the US (tier.net).

    Some are running apache with cpanel others are running apache with webadmin. All the same problem.

    My local host install on ubuntu. I installed a wamp server…. nothing works. And they are just default installs.

    It is not hosting related if you ask me.

    I just found one host where it does work…. That is interesting though…

    Moderator Marius L. J.

    (@clorith)

    I’m still inclined to think it might be hosting related, are any of these hosts WP-specific (have dedicated packages for WP for example)?

    We could try something I was thinking of earlier today, it’s not unheard of that they might block access to things in the admin area unless you have an appropriate referrer.

    on line 534, add a new line (right before $url = add_query_arg( $scrape_params, $url );)

    The new line should be`

    
    $headers['Referer'] = $url;
    

    It’s a bit of a hail-mary, but I’m curious if that might be it.

    https://i.imgur.com/2CJoLJY.jpg

    Does not help unfortunately. Still the same problem.

    Moderator Marius L. J.

    (@clorith)

    Well, it was a good thought, I’m going to have a look at the hosts you mentioned and see if I can come up with anything sensible, I’ll likely get back to you all in here later on in the day once I’ve done some digging 🙂

    Thank you ! Have a great weekend !

    +1 on this issue.

    My website is being hosted by GoDaddy. After a lengthy back and forth with their support, it seems like it’s not anything hosting-related.

    On my end I cleared my cache and cookies and still no luck. Like someone already mentioned I can update the stylesheet, just not anything PHP-related.

    EDIT: I also should mention that I am using a Custom Theme.

    • This reply was modified 4 weeks, 1 day ago by  jeffcrac.
    • This reply was modified 4 weeks, 1 day ago by  jeffcrac.
    • This reply was modified 4 weeks, 1 day ago by  jeffcrac.
    • This reply was modified 4 weeks, 1 day ago by  jeffcrac.
    Moderator Marius L. J.

    (@clorith)

    All right, I’m going to need a bit more data to replicate things here.

    Would y’all be so kind as to get http://wordpress.org/plugins/health-check, if you check under the debug tab it makes, there’s a copy and paste field with data that would greatly help here as I need to replicate scenarios 🙂

    I fixed my issue (at least as of this writing). Here are the steps I took:

    > Deactivated all of my Plugins and deleted those what I was not using
    > Cleared my WordPress cache
    > Cleared my Browser cache
    > Logged back in to see if my editor would save (which it did)
    > Activated my plugins one-by-one and while testing the save function

    Don’t know how long this will last, but hopefully we can narrow down from here.

    EDITED: For what it’s worth, this is one of the plugins I deleted. I should of ran a more thorough test to confirm if this plugin was the problem: https://wordpress.org/plugins/wp-clone-template/

    • This reply was modified 4 weeks, 1 day ago by  jeffcrac.
    BackuPs

    (@backups)

    here you go

    
    ### WordPress ###
    
    Version: 4.9
    Language: en_US
    Permalink structure: /%category%/%postname%
    Is this site using HTTPS?: No
    Can anyone register on this site?: No
    Default comment status: closed
    Is this a multisite?: Yes
    User Count: 7
    Site Count: 30
    Network Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    ### Active theme ###
    
    Name: Twenty Fifteen
    Version: 1.9
    Author: het WordPressteam
    Author website: https://nl.wordpress.org/
    Parent theme: Not a child theme
    Supported theme features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, custom-background, editor-style, customize-selective-refresh-widgets, custom-header, widgets
    
    ### Other themes (3) ###
    
    Twenty Thirteen Child With Revslider (do not remove) (twentythirteen-child): version 1.0.0 by Backups
    Twenty Thirteen (twentythirteen): version 2.3 by the WordPress team
    Twenty Twelve (twentytwelve): version 2.4 by the WordPress team
    
    ### Must Use Plugins (3) ###
    
    add-blog-id.php: No version or author information available
    custom.php: No version or author information available
    globalrobotstxt.php: No version or author information available
    
    ### Active Plugins (5) ###
    
    Health Check: version 0.5.0 by The WordPress.org community
    Menu Management Enhancer: version 1.1 by Chris Mavricos, SevenSpark
    Reveal IDs: version 1.5.2 by Oliver Schlöbe
    Stealth Login Page: version 4.0.0 by Jesse Petersen
    White Label Branding for WordPress Multisite: version Version 4.1.8.76640 by Alberto Lau (RightHere LLC)
    
    ### Inactive Plugins (0) ###
    
    ### Server ###
    
    Server architecture: Linux 2.6.32-042stab120.6 x86_64
    PHP Version: 7.1.11 (Supports 64bit values)
    PHP SAPI: cgi-fcgi
    PHP max input variables: 5000
    PHP time limit: 150
    PHP memory limit: 512M
    Upload max filesize: 128M
    PHP post max size: 128M
    cURL Version: 7.55.1 OpenSSL/1.0.2m
    SUHOSIN installed: No
    Is the Imagick library available: No
    
    ### Database ###
    
    Extension: mysqli
    Server version: 5.6.38
    Client version: mysqlnd 5.0.12-dev - 20150407 - $Id: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx $
    Database prefix: xxxxxxxxxxxxx_
    
    ### WordPress constants ###
    
    ABSPATH: /home/xxxxxxxxxxxxxxxxxx/public_html/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Enabled
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined
    
    ### Filesystem permissions ###
    
    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable
    
    
    • This reply was modified 4 weeks ago by  Marius L. J.. Reason: Fixed code tags
    Darryl.R

    (@darrylr)

    Just as an aside – I had the same error, resolved when I tossed the wp-spamshield plugin.

    Moderator Marius L. J.

    (@clorith)

    @backups Thank you for the debug data, that’s actually quite helpful, I see you have 3 Must Use plugins, did you also try removing these when disabling all plugins to see if they affected anything?

    BackuPs

    (@backups)

    Of course i already tried disabling them.It does not change anything. It would have made me laugh if they would have caused that as these plugins dont do anything that could cause such.

    They just add a site-id to the wp-admin area on the site list and a auto robots.txt and a remove action for redirect 404.

    <?php
    remove_action( 'template_redirect', 'maybe_redirect_404' );
    ?>

    I can send you the overview of a single website below.

    
    ### WordPress ###
    
    Version: 4.9
    Language: en_US
    Permalink structure: /%category%/%postname%
    Is this site using HTTPS?: Yes
    Can anyone register on this site?: No
    Default comment status: closed
    Is this a multisite?: No
    User Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    
    ### Active theme ###
    
    Name: Twenty Fifteen
    Version: 1.9
    Author: the WordPress team
    Author website: https://wordpress.org/
    Parent theme: Not a child theme
    Supported theme features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-logo, custom-background, editor-style, customize-selective-refresh-widgets, custom-header, widgets
    
    ### Other themes (3) ###
    
    Twenty Fourteen (twentyfourteen): version 2.1 by the WordPress team
    Twenty Thirteen (twentythirteen): version 2.3 by the WordPress team
    Twenty Twelve (twentytwelve): version 2.4 by the WordPress team
    
    ### Active Plugins (1) ###
    
    Health Check: version 0.5.0 by The WordPress.org community
    
    ### Inactive Plugins (1) ###
    
    Akismet Anti-Spam: version 4.0.1 by Automattic
    
    ### Server ###
    
    Server architecture: Linux 3.10.0-693.5.2.el7.x86_64 x86_64
    PHP Version: 7.1.11 (Supports 64bit values)
    PHP SAPI: litespeed
    PHP max input variables: 5000
    PHP time limit: 300
    PHP memory limit: 384M
    Upload max filesize: 128M
    PHP post max size: 128M
    cURL Version: 7.55.1 OpenSSL/1.0.2m
    SUHOSIN installed: No
    Is the Imagick library available: No
    
    ### Database ###
    
    Extension: mysqli
    Server version: 5.6.38
    Client version: mysqlnd 5.0.12-dev - 20150407 - $Id: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx $
    Database prefix: xxxxxx_
    
    ### WordPress constants ###
    
    ABSPATH: /home/xxxxxxxxxxxxx/public_html/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 384M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined
    
    ### Filesystem permissions ###
    
    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    
    

    I dont run any security plugin or whatever.

    Above is a pretty much normal install. It runs on tier.net

    But also on a local host with a non existing domain it does not work because the domain name cannot be resolved. That is something the code should actually check as it is useless to do a check for those installs.

Viewing 15 replies - 16 through 30 (of 126 total)
  • The topic ‘Can’t edit main theme php files after upgrading to 4.9’ is closed to new replies.