Support » Fixing WordPress » can’t edit images/links/any editable element inserted into post text editor

  • After inserting an images/links/any editable element into a post, you could go back and edit it by just highlighting the element in the text editor, which would then give you two icons (X for delete and pencil for editing). By clicking on the editing icon, you got a little box with all kinds of editing choices. Now, however, when I highlight the image, the buttons starts blinking and my clicks do not affect it.

    I tried to sign out and in again, delete the cache, but the problem still continues.
    It’s not a theme or plugin issue becouse it happening to me on several wordpress sites That do not have same plugins.

    Info:
    – I’m using chrome Version 61.0.3163.100
    – and WordPress Version 4.8.2
    – I run a RTL website and he language of the WordPress management panel is set to Hebrew

    site url: http://185.197.128.188/~gilord/dev.co.il

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • I have the same issue.
    It has began just recently.

    Moderator Sergey Biryukov

    (@sergeybiryukov)

    WordPress Dev

    The issue is fixed in 4.9 Beta, see ticket #42018.

    cjteamonline

    (@cjteamonline)

    .

    I have the same issue. I cannot edit the images and the image’s position once inserted in the post. I can’t add links either and I have to add links manually using the a href script. I have the latest version of WP.

    Strangely for the products (WooCommerce site) I do not have this problem. Only on the posts and the pages sections.

    This is happening to me now. Anyone have any answers?

    Edited to say: works fine in Chrome (problem occurs in Windows).

    • This reply was modified 1 year, 5 months ago by theculk4.

    @theculk4

    The problem occurs in Chrome for me.

    When I click the insert/edit link button and select the intended link, and hover the insert (arrow) button, the insert link container begins to rapidly blink, preventing me from inserting the link.

    A workaround is to click into the text box, tab to the submit button and press enter.

    I’ve just started having this problem a couple of weeks ago. After I insert a picture into my post, if I click on it to edit, the cursor jumps to the bottom of the page. Is anyone else experiencing this problem?

    I had the blinking issue as well in Chrome.
    Using another browser (Firefox in my case) solved my problem.

    +1 for this issue in Chrome. Using Twenty Seventeen theme and no plugins active.

    I’m having the same problem. Tried on Chrome and Firefox. Just started the website today so WordPress is up to date.

    Bill

    Having the same issue as well.

    This is happening in Chrome as well as the Safari browsers. Installing Firefox like everyone else in the thread seems to have cleared up the issue.

    This problem also happen to me, on a fresh new install. This only happen on the page for editing a content of type “page”, I have custom post type with the same editor, but on those pages it work.

    Same problem here, only when editing an image in a Page not a Post.

    New install WP 4.9.8, in Chrome and Safari. Turned off all Plugin incl.JetPack and Akismet. Still an issue.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘can’t edit images/links/any editable element inserted into post text editor’ is closed to new replies.