Support » Fixing WordPress » can't edit and publish posts

  • Resolved beautywithbrain

    (@beautywithbrain)


    Hi all,

    I’m trying to edit a draft but whenever I click on “save draft”, the changes I made to the post aren’t saved and it doesn’t let me publish it either. If I click on Publish, nothing happens. If I write a new post though, it works ok. It edits the changes and I can publish it, it’s only trying to make any changes to old drafts that doesn’t work.

    I have no idea why the editor isn’t working today. It was working fine yesterday but when I logged in this morning the problems started. I didn’t install any new plugins, nor made any changes to the theme or installation files. It just stopped working all of a sudden.

    Does anyone have any idea on how I can fix it?

    Thank you

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’ve tried using other browsers and clearing cookies but neither worked. I’ve then installed the FCKeditor plugin but I still have this problem.

    I don’t know what else I could try apart from reinstalling wordpress again but I have no idea how to do that. I’m not very techy and I’m scared I’m gonna break my site or something if I try.

    Does anyone know what else I can do?

    I’ve also downloaded the latest version of wordpress and copied the tinymce editor folder on my server, then delete cache, history and coojie from browser and restarted but it didn’t work. I can’t edit, publish nor even delete drafts. I don’t what else can I do. Can someone help please?

    I hear you screaming. I’ve having the same problem and don’t even know where to begin. I haven’t updated or changed anything in WP and this began yesterday in the middle of writing a post.

    I’m racking my brains. So far, nothing…

    I’m having the same problem, any luck getting this resolved?

    And yes this also began for us sometime yesterday or last night because I woke up this morning and it was broken, having worked fine yesterday morning.

    Ok I fixed it, for now at least. No idea what caused it but it looked like the database was corrupt. I’ve seen quite a few other posts on here the last few days about this so it must be some kind of bug.

    Repairing the database in phpmyadmin seemed to do the trick, only takes a second – http://php.about.com/od/mysqladministration/qt/repair_mysql.htm

    There are several people posting this problem, but not ‘everyone’. If we could put our heads together and see what we have in common? Web hosting?
    Firefox plugins? I’m running far afield in my thinking because I didn’t make any changes to WP. Is it as easy as flipping a switch on the ‘write permissions’?

    I’m hosted on Hostgator, if that rings any bells. What would they have to do with it? Don’t know.

    I’m using Hostgator as well, try repairing the database or having them repair it – that seemed to do the trick.

    Kfleming, that was interesting. I was also thinking toward PhpMyAdmin but don’t understand how to do this. My database is comprised of 42 tables. Do I click all the boxes?

    If you go into Cpanel under MySql Databases there is actually an option to repair Database that is much easier then going into phpmyadmin and messing around

    Thanks. I got it. I just chose the wp_post table and that seemed to work.

    My blog is hosted on Hostgator too. I’ve just repaired my database like you said and it worked! Thank you so much!

    Thanks Kfleming, saved me loads of time!

    It seems to be a Hostgator issue that started last night, my blogs are all hosted there as well- the repair worked like a charm, thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘can't edit and publish posts’ is closed to new replies.