Support » Fixing WordPress » Can't edit a certain page of upgrading to 3.6.1 and now 3.7

  • We updated our WordPress installation to 3.6.1 via the update link in the Admin section, and ever since then, we can’t edit one of the pages.

    The odd thing is, we can update every other page, but not that page.

    On that page, the edit box is blank and we can’t click on the TEXT tab to edit the HTML either. The toolbar that is usually right above the edit box is not even there. However, the page shows fine when a visitor views it in the browser.

    Here are the things that I tried:

    1. Added a line of code to the wordpress-config.php file. Didn’t fix it, even though it fixed it for others on this forum.

    Added the following:

    define(‘CONCATENATE_SCRIPTS’, false );

    to the wp-config.php file just before require_once(ABSPATH . ‘wp-settings.php’)

    2. Updated to WordPress 3.7 via the update button – not only did this not work, but it created another issue (see below)

    3. Manually updated it to 3.7 via FTP (FileZilla)

    4. Disabled all plugins

    None of the above worked permanently.

    Right after updating to 3.7, and again right after disabling the plugins, we were able to edit that page. But after making a change or two (just regular text, no code) and updating the page, it went back to not allowing us to edit it.

    As I mentioned above, right after I updated it to 3.7, on the page that can’t be edited, it allowed me to edit it (that didn’t last long), but another issue arose. Some of the pictures in the page are now big gray boxes that take up the width of the edit box.

    I just checked other pages, and there are other pages as well where some of the pictures are now gray boxes that take up the width of the editing window. But they still show fine to a visitor in the browser.

    Any suggestions?

Viewing 15 replies - 1 through 15 (of 15 total)
  • WPyogi


    Forum Moderator

    Have you tried clearing any caching on your site and browser?

    Tried another browser?

    Deactivated ALL plugins and switched to the default theme to rule out plugin and theme issues?

    Yes, I did everything you mentioned except clearing the cache on the site. But I can’t do that since I don’t have a cache plugin. WP doesn’t have its own cache to clear, does it? If it does, how do I clear it?

    Btw, when I changed it to the default WP theme and then back again, it did something to the wordpress-config.php file that created an error. So I had to reupload the wordpress-config.php file via the file manager in Cpanel so that I could see the site again.

    And applying the default theme didn’t fix the problem, unfortunately.

    Moderator kmessinger


    What theme are you using?

    WooThemes Fresh News

    I just noticed that the framework for the theme needs updating. Could that be a possible cause?

    Moderator kmessinger



    I just updated the framework. The ability to edit that page came back for a second, like it always does when we make a change, but then I activated Akismet again (ALL of the plugins were disabled), and then the ability to edit went away.

    I then disabled Akismet, refreshed the edit page, and it did not come back.

    Moderator kmessinger


    like it always does when we make a change

    So this happens often?

    Try working thru the masterlist.

    It only started happening after the 3.6.1 and 3.7 updates. It never used to happen.

    I just noticed that there was an update to theme files posted on 9.9.13 as well. So I’ll update them and see if that helps.

    I’ll also go through that master list. Thanks.

    I went through the master list and discovered that one of the issues that we’re having (a gray box taking up the width of the edit window taking place of a picture) has to do with a problem with photo captions, which is being worked on.

    But the main and more pressing issue of the edit window of a specific page being blank is unresolved. The content of the web page, however, can be viewed without issue in a browser. Also, we can select the text in the window and it will show up somewhat, as if it were white text, but we can’t edit it, nor can we click on the TEXT tab to edit the HTML.




    Forum Moderator

    This is in twentythirteen theme with ALL plugins deactivated?

    All plugins are disabled, but it’s with the theme that goes with the site. The last time I changed it to TwentyThirteen, it messed up the hompage of the site when I switched it back to the original theme, but I’ll switch it to 2013 again real quick to check it since I know how to fix the homepage if that happens again.

    With 2013, it is able to be edited, which is good news. But the gray box that takes place of the photos with a captions is now a blank space instead of a gray box. But I know you guys are working on that.

    How do I fix the theme? I updated both its framework and the theme files to the latest version, but it’s a no go.

    Btw, when I switched the theme back to the regular theme for the site just now, it didn’t mess up the homepage like it did last time, which is great.



    Forum Moderator

    Yeah, the image caption bug is fixed and WP3.7.1 is supposed to be out anytime.

    As to the theme, I’m afraid you’ll have to ask WooThemes about that – as these forums don’t support commercial products – partly because we have no access to them.

    Great. That’s good to hear. I assume that will be an automatic update?

    OK. Understood. Will do. Thanks.



    Forum Moderator

    Yep, so far as we’ve heard and it should be “soon” :).

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Can't edit a certain page of upgrading to 3.6.1 and now 3.7’ is closed to new replies.