Support » Plugins and Hacks » [Resolved] Cant drag Widgets !

[Resolved] Cant drag Widgets !

  • I am aware that this question has been asked many times here, plus i also did a search and read every topic i could possibly find here on the support forums. But i cant find a response that would correct my problem.

    Everything seems to be installed fine. The plugin activated, copied the optional php files to the default and classic themes AND the scriptaculous files are in wp-include/js/scriptaculous. Everything is according to the readme.

    I had tried to use the widgets yesterday on my previous installation and it worked then. but today after a fresh install of WP 2.1 and the latest release of the widgets plugin 1.1.20070127 , i cant tend to drag and drop.

    Any suggestions ?
    Thankx in advance

Viewing 15 replies - 1 through 15 (of 38 total)
  • What browser, browser version and OS are you running? We’ve noted issues when running IE7 on WinXP over at wordpress.com.

    One trick we did figure out though. Before you drop the widget that you’re dragging, make sure you move it in such a way that the other widgets move out of it’s way. That way you can tell that the widget system has noticed that something is going on.

    Hope this helps,

    I am using Firefox and WindowsXP Home. I also have IE7 installed and checked on that, and it doesn’t work there either.

    I tried what u just suggested, but when u drag a widget say: The first row has 4 and i take the 2nd one and drag it upwards without touching the other widgets into the sidebars space, all that happens is the widget box gets highlighted (selected). I get the cross cursor but it still just highlights the widget.

    Am i having some wrong combination of tools or is it just the incompatibility ?

    This solves most widget related issues:
    1. Download the latest version of the widgets plugin here: http://downloads.wordpress.org/plugin/widgets.zip

    2. Unzip it.

    3. Drop the widgets directory you just unzipped into your blog’s plugins directory. Do not move any files anywhere else, everything will work just fine if you leave it together in the widgets directory.

    That fixes most drag and drop issues, but you may have your browsers ad-blocker interfering or something. Check that sort of thing.

    Just did those steps again and its still not working. If browser settings are considered then i guess i havent changed any settings since the time i installed FF. And i have no ad blocker programs installed.

    Java and javascripts are both enabled in FF.

    EDIT: sweet bbpress upgrade 🙂 Good work guys. Newayz i just d’loaded Opera and tried dragging it there too, but still cant be dragged.
    I am not a php guru, but i am guessing its a widget+WP 2.1 compatibility issue and not the browsers fault.

    On the widgets page, hit CTRL-F5 to force a complete reload.
    Failing that, clear your browser’s cache.
    Failing that, try another browser.
    Failing that… well… I haven’t the faintest idea. Get an expert to actually look at it for you.

    Did ctrl+f5, cleared browsers cache and as i mentiond in my earlier post edit, i d’loaded opera and it still doesnt work. can anyone be kind enuf to see if it works for me ?

    Have you tried from another PC?
    Are you running any “Internet Security” suites (norton, zonealarm, mcafee, etc) on your PC? If so, try temporarily disabling it to see if that’s “protecting” you.

    I’m having the same problem… I’m getting this on the “Sidebar Widgets” page if it helps.

    Error: Element.childrenWithClassName is not a function
    Source File: http://www.site.com/wp-includes/js/scriptaculous/dragdrop.js?ver=1.6.1
    Line: 640


    Hmm.. I’m getting that problem now with the latest version too. Lemme look into it.

    Okay, found it. The latest widgets code has a bug in it.

    Find this in widgets.php (at line 203):

    wp_enqueue_script( 'scriptaculous-dragdrop' );

    Add this immediately after that line:

    wp_enqueue_script( 'scriptaculous-effects' );

    That fixed it for me.

    Fixed it for me too! Thanks a million!

    whooot .. Otto ur a genius ! Fix for me too 🙂 Thankx a ton buddy !

    I have another problem that might have to do with this. Once I drag them in to the column I am unable to drag them out. I also downloaded the wp-scriptaculous.js file as indicated in http://trac.wordpress.org/ticket/3703 because that was also missing from the install. However I cannot seem to find the solution to dragging the widgets out of the left column.

    Also I don’t know if this helps but my “right column” is actually a column that is 100% width and resides under the left column. Is this how it is suppose to be shown?

    Widgets 1.2.1 should fix:

    1. Drag and Drop issue (not loading all the correct JS files)
    2. Missing wp-scriptaculous.js file. The plugin works around this core bug in WP 2.1


    Hmm, a new problem after doing the recommended steps. I get a new error, this time on line 204.

    Fatal error: Call to undefined function: wp_deregister_script() in /home/publiusp/public_html/feelingright/wp-content/plugins/widgets/widgets.php on line 204

    Any thoughts?

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘[Resolved] Cant drag Widgets !’ is closed to new replies.
Skip to toolbar