[resolved] Cant drag Widgets ! (39 posts)

  1. dhanesh
    Posted 9 years ago #

    I am aware that this question has been asked many times here, plus i also did a search and read every topic i could possibly find here on the support forums. But i cant find a response that would correct my problem.

    Everything seems to be installed fine. The plugin activated, copied the optional php files to the default and classic themes AND the scriptaculous files are in wp-include/js/scriptaculous. Everything is according to the readme.

    I had tried to use the widgets yesterday on my previous installation and it worked then. but today after a fresh install of WP 2.1 and the latest release of the widgets plugin 1.1.20070127 , i cant tend to drag and drop.

    Any suggestions ?
    Thankx in advance

  2. drmike
    Posted 9 years ago #

    What browser, browser version and OS are you running? We've noted issues when running IE7 on WinXP over at wordpress.com.

    One trick we did figure out though. Before you drop the widget that you're dragging, make sure you move it in such a way that the other widgets move out of it's way. That way you can tell that the widget system has noticed that something is going on.

    Hope this helps,

  3. dhanesh
    Posted 9 years ago #

    I am using Firefox and WindowsXP Home. I also have IE7 installed and checked on that, and it doesn't work there either.

    I tried what u just suggested, but when u drag a widget say: The first row has 4 and i take the 2nd one and drag it upwards without touching the other widgets into the sidebars space, all that happens is the widget box gets highlighted (selected). I get the cross cursor but it still just highlights the widget.

    Am i having some wrong combination of tools or is it just the incompatibility ?

  4. This solves most widget related issues:
    1. Download the latest version of the widgets plugin here: http://downloads.wordpress.org/plugin/widgets.zip

    2. Unzip it.

    3. Drop the widgets directory you just unzipped into your blog's plugins directory. Do not move any files anywhere else, everything will work just fine if you leave it together in the widgets directory.

    That fixes most drag and drop issues, but you may have your browsers ad-blocker interfering or something. Check that sort of thing.

  5. dhanesh
    Posted 9 years ago #

    Just did those steps again and its still not working. If browser settings are considered then i guess i havent changed any settings since the time i installed FF. And i have no ad blocker programs installed.

    Java and javascripts are both enabled in FF.

    EDIT: sweet bbpress upgrade :) Good work guys. Newayz i just d'loaded Opera and tried dragging it there too, but still cant be dragged.
    I am not a php guru, but i am guessing its a widget+WP 2.1 compatibility issue and not the browsers fault.

  6. On the widgets page, hit CTRL-F5 to force a complete reload.
    Failing that, clear your browser's cache.
    Failing that, try another browser.
    Failing that... well... I haven't the faintest idea. Get an expert to actually look at it for you.

  7. dhanesh
    Posted 9 years ago #

    Did ctrl+f5, cleared browsers cache and as i mentiond in my earlier post edit, i d'loaded opera and it still doesnt work. can anyone be kind enuf to see if it works for me ?

  8. Chris_K
    Posted 9 years ago #

    Have you tried from another PC?
    Are you running any "Internet Security" suites (norton, zonealarm, mcafee, etc) on your PC? If so, try temporarily disabling it to see if that's "protecting" you.

  9. crpearson
    Posted 9 years ago #

    I'm having the same problem... I'm getting this on the "Sidebar Widgets" page if it helps.

    Error: Element.childrenWithClassName is not a function
    Source File: http://www.site.com/wp-includes/js/scriptaculous/dragdrop.js?ver=1.6.1
    Line: 640


  10. Hmm.. I'm getting that problem now with the latest version too. Lemme look into it.

  11. Okay, found it. The latest widgets code has a bug in it.

    Find this in widgets.php (at line 203):

    wp_enqueue_script( 'scriptaculous-dragdrop' );

    Add this immediately after that line:

    wp_enqueue_script( 'scriptaculous-effects' );

    That fixed it for me.

  12. crpearson
    Posted 9 years ago #

    Fixed it for me too! Thanks a million!

  13. dhanesh
    Posted 9 years ago #

    whooot .. Otto ur a genius ! Fix for me too :) Thankx a ton buddy !

  14. nberardi
    Posted 9 years ago #

    I have another problem that might have to do with this. Once I drag them in to the column I am unable to drag them out. I also downloaded the wp-scriptaculous.js file as indicated in http://trac.wordpress.org/ticket/3703 because that was also missing from the install. However I cannot seem to find the solution to dragging the widgets out of the left column.

    Also I don't know if this helps but my "right column" is actually a column that is 100% width and resides under the left column. Is this how it is suppose to be shown?

  15. Michael Adams (mdawaffe)
    Posted 9 years ago #

    Widgets 1.2.1 should fix:

    1. Drag and Drop issue (not loading all the correct JS files)
    2. Missing wp-scriptaculous.js file. The plugin works around this core bug in WP 2.1


  16. publius
    Posted 9 years ago #

    Hmm, a new problem after doing the recommended steps. I get a new error, this time on line 204.

    Fatal error: Call to undefined function: wp_deregister_script() in /home/publiusp/public_html/feelingright/wp-content/plugins/widgets/widgets.php on line 204

    Any thoughts?

  17. publius: This version of widgets only works with WP 2.1 and up. It won't work with the 2.0 series.

  18. Michael Adams (mdawaffe)
    Posted 9 years ago #

    I thought there was a version available for download that would work with WP 2.0. I do not see one.

    I'll put one together early this week.

  19. Michael Adams (mdawaffe)
    Posted 9 years ago #

    This version should work with WP 2.0.x


  20. vkaryl
    Posted 9 years ago #

    Huh. Y'know, I'm using the oldest version of widgets on 2.0+ installs all over the place; I have a couple of clients who installed 2.1 and are using the oldest version (since that's what they had available, and they didn't check for newer). NONE of us are having any trouble of this sort with either version of wp. And we didn't move the js stuff anywhere either....

  21. chuchris
    Posted 9 years ago #

    It still doesn't work for me. Funny though, it was working for my 2.1 until about a week ago, and I don't think I messed around with anything. I've tried installing the new version and everything outlined here. Anyone have any updates?

  22. clemini
    Posted 9 years ago #

    publius: This version of widgets only works with WP 2.1 and up. It won't work with the 2.0 series.

    otto, i have the same problem than publius.

    i'm using WP2.1 and i'd like to install v1.2.1 of wigets but there is no scriptaculous files in this link

    where can i have the good scriptaculous files related to widgets 1.2.1 please?

  23. @clemini: The scriptaculous files are built into WordPress 2.1. You don't need any other files. Just install the latest widgets plugin. It will work.

  24. clemini
    Posted 9 years ago #

    thank you otto.

    i did what you recommended but now i have the same pb than publius

    i have this message when i press the sidebar widgets button:

    "Fatal error: Call to undefined function: wp_deregister_script() in /homepages/29/d196333458/htdocs/wp-content/plugins/widgets/widgets.php on line 204"

    and this is the same message for every theme i tried

    (i am using WP2.1 and the very last version of widgets plugin).

    is there any solution for this issue?

  25. If you are getting this error:
    "Call to undefined function: wp_deregister_script()"
    Then you are *not* using WP 2.1.

    That function is defined in script-loader.php which is include'd from the main wp-settings.php file. It cannot be "undefined" unless you have a previous version of WordPress.

    If you recently upgraded, then you may have not uploaded all the 2.1 files. Double check every file and make sure that you actually did upgrade it.

  26. vkaryl
    Posted 9 years ago #

    chuchris: sounds like a change in the backend programs on your host. Check to see if they might have upgraded something like php, mysql or apache....

  27. clemini
    Posted 9 years ago #

    hey thank you so much otto you were right ;)

    i was sure to have the last version since i downloaded 1 week ago but actually it was not the case.
    now i'm gonna try to understand how can i see my 2 sidebar columns in my widgets menu and not only one

    thank you again anyway

  28. chuchris
    Posted 9 years ago #


    That's a possibility. How do I go about resolving the issue though? Overwriting the WP install and hoping things will go fine? Re-running the upgrade script?

  29. vkaryl
    Posted 9 years ago #

    chuchris: you need to verify with your host what they upgraded first.

    Then post back with that info, and we'll see what could be done.

  30. chuchris
    Posted 9 years ago #

    I've sent in a question, and they haven't replied yet (I use a great free host called Grinhost, with no ads). They're using PHP version 4.4.4. I can probably get more information from cPanel if you let me know what to look for.

    I think the problem is that WordPress isn't given permission or can't modify my files in my site. It can access MySQL stuff, so I've continued to blog and post new entries. However, I can't change any template files or widget orders from my backend; I can only change those by using FTP.

    Does this info help? I've tried a lot so far, and it all seems to point in this direction. I'm not an advanced user of Unix, but maybe it has something to do with granting permission to WordPress?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.