Support » Plugin: Simply Static » Can’t download the zip file

  • Using version 2.07 of the Simply Static plugin
    Linux (bitnami on aws lightsail)
    I get this error message when clicking to download the generated zip file:

    This site can’t be reached
    The webpage at http://example.com/wp-admin/admin.php?simply-static_zip_download=simply-static-1-1492594903.zip might be temporarily down or it may have moved permanently to a new web address.
    ERR_INVALID_RESPONSE

    * I replaced the website address with example.com in that error messsage as we want to keep the server address private.

    I can download the zip file via ftp, but I need to make this a point and click download for the company I set this server up for.

    I’ve reset to defaults in the settings, but still can’t download the zip file by clicking on the link after it’s generated.

    If I enter in the full link to the file in the browser http://example.com/wp-content/plugins/simply-static/static-files/simply-static-1-1492594903.zip the download starts, so I’m assuming that it’s not a permission problem but rather a redirect problem??

Viewing 4 replies - 1 through 4 (of 4 total)
  • Deactivating and reactivating didn’t work. Uninstalling and reinstalling the plugin didn’t work either.

    Plugin Contributor Scott at Code of Conduct

    (@codeofconduct)

    Hi tdavenport,

    That’s a mighty strange issue. The link doesn’t work if you click on it, but if you copy the URL and paste it into the browser then it works…

    It sounds like it’s not an issue with Simply Static or even your server, but more likely something with your browser or computer. Have you tried it in Chrome incognito, or Firefox? Do you have any antivirus running? Those might be some things to try to see if they work, and then narrow it down from there.

    For what it’s worth, I haven’t heard of this issue from anyone else.

    Best,
    Scott

    Maybe I wasn’t clear enough about that.

    If you look at the error message you notice that the original link looks like this: http://example.com/wp-admin/admin.php?simply-static_zip_download=simply-static-1-1493842719.zip

    That link produces the error. I assumed that “admin.php?simply-static_zip_download=simply-static-1-1493842719.zip” was just a redirect to the actual location of the file, so I tried entering the full address into the browser: http://example.com/wp-content/plugins/simply-static/static-files/simply-static-1-1492594903.zip, and that link actually works.

    That’s why I think it’s a redirect problem. That first link is not redirecting to the correct location/file.

    I ran into this issue and it has to do with file size > memory limit with output buffering on.

    What the plugin should do in at least the download_file() function is to check the output buffer level and flush it out until all levels have been flushed.

    see the note on php.net/readfile

    Note:
    readfile() will not present any memory issues, even when sending large files, on its own. If you encounter an out of memory error ensure that output buffering is off with ob_get_level().

    • This reply was modified 1 year, 8 months ago by  nobleclem.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Can’t download the zip file’ is closed to new replies.