Support » Fixing WordPress » Can't do admin login, several approaches all leaving me out in the dark

Viewing 11 replies - 1 through 11 (of 11 total)
  • Eight hours later and I’ve not left my seat trying to resolve this.

    Other things tried:

    Full reinstall again (in different directories too)
    Added this to wp-config near top under <?php
    @define(‘ADMIN_COOKIE_PATH’, ‘/’);
    Tried adding these to the theme functions.php on top and/or in the wp-config file at bottom (with no extra breaks or spaces)

    (note: I added the www. in both as well as in the siteurl field in the database as another attempt)

    After fresh installs I manually changed permissions via commandline:
    for directories
    find /var/www/vhosts/ -type d -exec chmod 755 {} \;
    for files
    find /var/www/vhosts/ -type f -exec chmod 644 {} \;

    I chown’d my files to be sure they were all using the right admin:group name with:

    open putty, cd to /var/www/vhosts/
    chown -R adminName:groupName /var/www/vhosts/

    Still no progress.

    I also dumped browser cache’s, disabled all plugins and .htaccess file many times. Tried on other computers and even my cell phone. All give same results so it must be server related.

    Any help would be appreciated as I can see and navigate site but, not use admin backend.

    Endless admin-loop hell for sure.


    I’m a bit desperate here. Found out one issue is I was using root to create everything as that’s the login/pass information my provider gave. Now have a proper admin account in Plesk.

    What’s odd is for every domain on my server I cannot login to the WP admin using wp-admin or wp-login.php. This leads me to think it is a server issue no? But, I have no idea of where to look to resolve this. Base_dir? Php.ini? and a million other things.

    I find a lot of people describing the problem of a disappearing login/password but, not finding any meat as to the source.


    What php version does your server have? Is it sufficient? All required scripts running? I was missing one on my first install which gave the same issue.

    Hey BeautyPirate,

    I’m using PHP 5.3.3

    I just can’t figure why every single site is having this issue. All that happens is I add my username and password and it appears the page isn’t reloading – the data just disappears. I checked my error logs and activity logs as well and no obvious clues there either.


    BTW, I have 20 WP sites disabled now. Really depressing and my clients are beyond irked right now. Thanks for any help.

    I have the same problem , i am a very new user for wP . was surfing around trying to learn .. I accidently log on to the 5 minutes WP installation page. ( have yet to key in any info thou ) but now , couldt get out from that page, and not able to log on to my doman Cpanel admin page…

    I was hoping to get help from the greater community and tried to post a more succinct message that wouldn’t seem so intimidating (i.e. the dozen+ things I’ve tried to remedy this issue which is still persisting. The WP gods said no and deleted that one.

    Suffice to say I have 20 websites that are inoperable right now from an administrative perspective. I have spent over two days researching this and am pleading for help.


    Wow. The help via these forums is stunningly FLAT.


    I got the same issue.. But i needed to edit my wp-config.php and changed the ‘ characters..
    Please check this thread

    G’day bizwizkid. Did you find any joy eventually with your Plesk WP sites? I’ve just changed to Plesk (it was cheap hosting!!) but so far it is taking so much time I’m not sure it was worth it. Just wondered if you were able to resolve the problems you were having…

    I am 4 days into a migration to a VPS solution using Plesk and I HATE it. It is of course all operator error and/ignorance of Plesk.

    Migration process worked fine but using Plesk for what I think is a Plesk only task hooks into WP and makes changes Arg! I can see the benefits for a fresh vanilla site or hosting providers but the hurdles to undo Plesk’s desire to be the interface or control for WP admin is now unbearable. Undoing it is another matter.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Can't do admin login, several approaches all leaving me out in the dark’ is closed to new replies.