Support » Plugin: Members - Membership & User Role Editor Plugin » Can’t dismiss plugin ratings nag

  • Immediately after installing the plugin (v3.1.3) the “Are you enjoying Members?” admin notification cannot be dismissed. I have tried clicking the X, clicking “Not Really…” (which is how this issue makes me feel), and “Yes I love it”. It comes back no matter what.

Viewing 7 replies - 1 through 7 (of 7 total)
  • uptree

    (@uptree)

    To add to this, I am able to dismiss it, but it comes back like every other day. I’m so tired of developers bloating up the admin with this kind of crap. If I close it, it should be gone for good.

    Plugin Author Caseproof

    (@caseproof)

    Hi @mrwweb @uptree

    Members stores members_review_prompt_delay transient when the user doesn’t want to review right now so they will be asked after one week. It also stores members_review_prompt_removed option when users review or select the option that they’ve already reviewed the plugin. The transient might not work if you have a plugin that cleans out transients. However, it shouldn’t happen for members_review_prompt_removed option.

    Thread Starter mrwweb

    (@mrwweb)

    @caseproof If you’re saying that this problem shouldn’t be happening if I click the “X”, then I can tell you that something is broken.

    Clicking the “X” removes the message on the page but then it’s back on the next page load.

    cartpauj

    (@cartpauj)

    Try flushing caches, and maybe rebooting server then. I can’t duplicate this on a site with no caching, but I have heard other reports of this from sites with database and/or object caching enabled.

    Thread Starter mrwweb

    (@mrwweb)

    To follow up on this, I was able to dismiss the notice by disabling the SiteGround caching plugin, dismissing the notice, and then re-enabling the caching plugin.

    That said, @caseproof I don’t run into this issue with any other plugins regularly for 20+ sites hosted on SiteGround, so I’d encourage you to see what it is about your specific admin notification that doesn’t work in environments like this. There must be ways to address it.

    Thread Starter mrwweb

    (@mrwweb)

    Another update. What I did in the previous post only briefly worked. Now it’s back and still can’t be dismissed.

    Thread Starter mrwweb

    (@mrwweb)

    Was finally able to remove it by using wp-cli to set the option directly:

    $ wp option set members_review_prompt_removed 1

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.