Support » Plugin: Advanced Ads – Ad Manager & AdSense » Can’t disable wizard – ‘Uncaught RangeError: Maximum call stack size exceeded’

  • Resolved justlevine

    (@justlevine)


    If I try to disable the wizard when creating an ad, I get an error in the developer console:
    `
    Uncaught RangeError: Maximum call stack size exceeded
    at ea.select (jquery.js?ver=1.12.4-wp:2)
    at Function.ea (jquery.js?ver=1.12.4-wp:2)
    at Function.jQuery.find (jquery-migrate.js?ver=1.4.1:290)
    at n.fn.init.find (jquery.js?ver=1.12.4-wp:2)
    at n.fn.init.jQuery.fn.find (jquery-migrate.js?ver=1.4.1:677)
    at jQuery.fn.init.n.fn.init (jquery.js?ver=1.12.4-wp:2)
    at new jQuery.fn.init (jquery-migrate.js?ver=1.4.1:241)
    at n (jquery.js?ver=1.12.4-wp:2)
    at Object.close (wizard.js?ver=1.14.9:68)
    at HTMLAnchorElement.<anonymous> (wizard.js?ver=1.14.9:30)
    `
    As a result, not just does the wizard not get replaced with the full form (ideally one that would include the debug ad option – since I’m not even seeing dummy ads), but even the wizard next button stops working.

    Suggestions?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Thomas M

    (@webzunft)

    Hi justlevine,

    thanks for reaching out.

    I have not seen this kind of issue before. When you click on the “Stop Wizard” button and reload the page, do you still see the Wizard?

    If so, would you be able to test for plugin conflicts? You can use the Health Check plugin to do that for your user only, so that normal visitors would not see any changes in the frontend.

    Thanks,
    Thomas

    justlevine

    (@justlevine)

    The issue in wizard.js is line 69: jQuery('*').removeClass('advads-hide');, when it probably should be jQuery('.advads-hide').removeClass('advads-hide);.

    I’m assuming the conflict _on my site specifically_ is caused by Query Monitor (since it creates hundreds of elements on the page), but I still have more testing to do.

    Since its a fatal error in jquery, it stops any other scripts from firing, aka before the ajax function responsible for disabling the wizard gets sent, so a refresh on its own wont cut it.

    My workaround is to copy/paste the ajax function directly into the Chrome Dev Console and _then_ refresh the page:

    jQuery.ajax({
    		    type: 'POST',
    		    url: ajaxurl,
    		    data: {
    			    action: 'advads-save-hide-wizard-state',
    			    hide_wizard: true, //set to false to reenable
    			    nonce: advadsglobal.ajax_nonce,
    		    },
    	    }); 
    
    • This reply was modified 10 months ago by justlevine.
    • This reply was modified 10 months ago by justlevine.
    • This reply was modified 10 months ago by justlevine.
    Plugin Author Thomas M

    (@webzunft)

    Thank you, justlevine. I agree that this selector could be improved and will do so in the next release.

    Best regards,
    Thomas

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can’t disable wizard – ‘Uncaught RangeError: Maximum call stack size exceeded’’ is closed to new replies.