Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Can’t disable Notifications anymore

  • Resolved Garrett Hyder

    (@garrett-eclipse)


    Hello,

    There used to be a toggle which would disable the Notifications panel, it seems to be missing in the latest version?

    How can I go about disabling that panel, I manage several clients sites so hook in Jetpack with our corporate account so that Notifications panel has info from several sites which I don’t want the client to view.

    Thank you

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’ve been looking for this too.
    Also how to disable the Feedback/Contact form module.

    Where did these options go?

    Thread Starter Garrett Hyder

    (@garrett-eclipse)

    Ya it’s definitely frustrating that those options disappeared.
    To disable Notifications I went into the database in the end and edited the serialized array for the jetpack_active_modules option in wp_options table.
    As it’s a serialized array you have to make sure you’re updating the array count at the beginning when removing the items. Notifications are called notes in that array.

    Example
    BEFORE
    a:19:{i:0;s:18:"after-the-deadline";i:1;s:20:"custom-content-types";i:2;s:10:"custom-css";i:3;s:21:"enhanced-distribution";i:5;s:8:"json-api";i:6;s:5:"latex";i:7;s:6:"manage";i:8;s:5:"notes";i:9;s:10:"omnisearch";i:10;s:13:"post-by-email";i:11;s:9:"publicize";i:13;s:10:"shortcodes";i:14;s:10:"shortlinks";i:15;s:5:"stats";i:18;s:17:"widget-visibility";i:19;s:7:"widgets";i:20;s:8:"carousel";i:21;s:6:"photon";i:24;s:13:"tiled-gallery";}
    AFTER
    a:18:{i:0;s:18:"after-the-deadline";i:1;s:20:"custom-content-types";i:2;s:10:"custom-css";i:3;s:21:"enhanced-distribution";i:5;s:8:"json-api";i:6;s:5:"latex";i:7;s:6:"manage";i:9;s:10:"omnisearch";i:10;s:13:"post-by-email";i:11;s:9:"publicize";i:13;s:10:"shortcodes";i:14;s:10:"shortlinks";i:15;s:5:"stats";i:18;s:17:"widget-visibility";i:19;s:7:"widgets";i:20;s:8:"carousel";i:21;s:6:"photon";i:24;s:13:"tiled-gallery";}

    Hope that helps until Jetpack and re-introduce those options.

    Leaving this unresolved as this is a workaround and not a proper resolution.
    Cheers

    Plugin Contributor Lisa Schuyler

    (@lschuyler)

    Hi @garrett-eclipse!

    In our latest design we removed many of the individual settings. You can read more about this decision here:

    https://jetpack.com/2017/04/04/settings-overhaul-redesign/

    That said, you can still access a list of your Jetpack modules in order to turn off the Notifications or the Contact Form.

    Go to the Jetpack -> Dashboard page on your site’s dashboard. Scroll to the bottom of the page and click on the “Debug” link.

    Then, look for the link that says “Access the full list of Jetpack modules available on your site.”

    Hope that helps! Let me know if we can help further.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Can’t disable Notifications anymore’ is closed to new replies.